toolchain: update Linaro ARM external toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Sep 2013 16:06:39 +0000 (18:06 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 15 Sep 2013 21:28:17 +0000 (23:28 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 8e25aa3a637d9d8904e84c060b62211995a6819c..11658ddbcf7cccdf74217cab0cd63aecdd30a550 100644 (file)
@@ -3,8 +3,8 @@ if BR2_TOOLCHAIN_EXTERNAL
 choice
        prompt "Toolchain"
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
-       bool "Linaro 2013.06"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_08
+       bool "Linaro 2013.08"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -15,16 +15,17 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.06 (based on gcc 4.8), Linaro GDB 2013.06 (based on
-         GDB 7.6), eglibc 2.15. It generates code that runs on all
-         Cortex-A profile devices, but tuned for the Cortex-A9. The
-         code generated is Thumb 2, with the hard floating point
-         calling convention, and uses the VFPv3-D16 FPU instructions.
+         GCC 2013.08 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+         GDB 7.6), eglibc 2.17, Binutils 2013.06 (based on 2.23). It
+         generates code that runs on all Cortex-A profile devices,
+         but tuned for the Cortex-A9. The code generated is Thumb 2,
+         with the hard floating point calling convention, and uses
+         the VFPv3-D16 FPU instructions.
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
-       bool "Linaro 2013.05"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_07
+       bool "Linaro 2013.07"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -35,16 +36,17 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.05 (based on gcc 4.8), Linaro GDB 2013.05 (based on
-         GDB 7.6), eglibc 2.15. It generates code that runs on all
-         Cortex-A profile devices, but tuned for the Cortex-A9. The
-         code generated is Thumb 2, with the hard floating point
-         calling convention, and uses the VFPv3-D16 FPU instructions.
+         GCC 2013.07 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+         GDB 7.6), eglibc 2.17, Binutils 2013.06 (based on 2.23). It
+         generates code that runs on all Cortex-A profile devices,
+         but tuned for the Cortex-A9. The code generated is Thumb 2,
+         with the hard floating point calling convention, and uses
+         the VFPv3-D16 FPU instructions.
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
-       bool "Linaro 2013.04"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
+       bool "Linaro 2013.06"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -55,11 +57,12 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.04 (based on gcc 4.7), Linaro GDB 2012.12 (based on
-         GDB 7.5), eglibc 2.15. It generates code that runs on all
-         Cortex-A profile devices, but tuned for the Cortex-A9. The
-         code generated is Thumb 2, with the hard floating point
-         calling convention, and uses the VFPv3-D16 FPU instructions.
+         GCC 2013.06 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+         GDB 7.6), eglibc 2.17, Binutils 2013.06 (based on 2.23). It
+         generates code that runs on all Cortex-A profile devices,
+         but tuned for the Cortex-A9. The code generated is Thumb 2,
+         with the hard floating point calling convention, and uses
+         the VFPv3-D16 FPU instructions.
 
          To use this toolchain, you must disable soft float usage.
 
@@ -813,9 +816,9 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
 
 config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        string
+       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_08
+       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_07
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305
index d5023cfc1dc42bd4c059f354f2a16d870b26355e..6a8d8a61d61ce78b8a91759b6a720300283486ee 100644 (file)
@@ -229,15 +229,15 @@ define TOOLCHAIN_EXTERNAL_FIXUP_CMDS
        mv $(@D)/arago-2011.09/armv5te/* $(@D)/
        rm -rf $(@D)/arago-2011.09/
 endef
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04),y)
-TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/13.04/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.7-2013.04-20130415_linux.tar.xz
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05),y)
-TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/13.05/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.8-2013.05_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06),y)
 TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/13.06/components/toolchain/binaries/
 TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.8-2013.06_linux.tar.xz
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_07),y)
+TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/13.07/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.8-2013.07-1_linux.tar.xz
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_08),y)
+TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/13.08/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.8-2013.08_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
 TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE = mips-2012.03-63-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2