package/libsoup: add optional dependency for gobject-introspection
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 17:24:54 +0000 (10:24 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Mar 2020 10:16:48 +0000 (11:16 +0100)
If gobject-introspection is selected, explicitly set --with-introspection in
the configure options and add a dependency for gobject-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libsoup/libsoup.mk

index 95bd68201065097a34d5dcbd96ca2f1e54311b83..07c9d787bda2d9489a460249cd8b02eead80b334 100644 (file)
@@ -16,6 +16,13 @@ LIBSOUP_CONF_OPTS = --disable-glibtest --enable-vala=no --with-gssapi=no
 LIBSOUP_DEPENDENCIES = host-pkgconf host-libglib2 \
        libglib2 libxml2 sqlite host-intltool
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBSOUP_CONF_OPTS += --with-introspection
+LIBSOUP_DEPENDENCIES += gobject-introspection
+else
+LIBSOUP_CONF_OPTS += --without-introspection
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSOUP_GNOME),y)
 LIBSOUP_CONF_OPTS += --with-gnome
 else