fs/common.mk: add host-mkpasswd if PACKAGES_USERS is not empty
authorSamuel Martin <s.martin49@gmail.com>
Wed, 22 Jan 2014 20:59:41 +0000 (21:59 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 22 Jan 2014 21:08:28 +0000 (22:08 +0100)
When using a custom rootfs skeleton, the host-mkpasswd target is not
automatically built, even if some packages add users (i.e. when
PACKAGES_USERS is not empty).

In this case, the rootfs generation may fail because the mkpasswd
provided by some distribution does not support all options used in the
mkusers script.

This patch avoids such trouble by automatically adding the host-mkpasswd
package to the dependency list of the rootfs targets if users needs
to be created.

[Peter: minor rewording of commit message]
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/common.mk

index aa9d961964cd26b3f59550003ba384119c9aa76f..9f3262019bc137b34a5b3828604efb20994d5f35 100644 (file)
@@ -37,7 +37,8 @@ USERS_TABLE = $(BUILD_DIR)/_users_table.txt
 define ROOTFS_TARGET_INTERNAL
 
 # extra deps
-ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs
+ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs \
+       $(if $(PACKAGES_USERS),host-mkpasswd)
 
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)_GZIP),y)
 ROOTFS_$(2)_COMPRESS_EXT = .gz