Makefile: rename non-user-facing variable
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 13 Apr 2014 20:42:37 +0000 (22:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Apr 2014 18:56:17 +0000 (20:56 +0200)
Variables should be prefixed with BR_ when they are not user-facing.

As a side effect, the new variable is prettier than the previous one. :-)

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
package/pkg-generic.mk

index 41c51c6b2a637f2e837b5243b7470361bcd49a62..b0eec7f9a7f3bddcec8c84d4b3e55f73ba13c87d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -149,7 +149,7 @@ endif
 
 # Need that early, before we scan packages
 # Avoids doing the $(or...) everytime
-_BR2_GRAPH_OUT := $(or $(BR2_GRAPH_OUT),pdf)
+BR_GRAPH_OUT := $(or $(BR2_GRAPH_OUT),pdf)
 
 BUILD_DIR:=$(BASE_DIR)/build
 BINARIES_DIR:=$(BASE_DIR)/images
@@ -662,18 +662,18 @@ graph-build: $(O)/build/build-time.log
        @install -d $(O)/graphs
        $(foreach o,name build duration,./support/scripts/graph-build-time \
                                        --type=histogram --order=$(o) --input=$(<) \
-                                       --output=$(O)/graphs/build.hist-$(o).$(_BR2_GRAPH_OUT) \
+                                       --output=$(O)/graphs/build.hist-$(o).$(BR_GRAPH_OUT) \
                                        $(if $(BR2_GRAPH_ALT),--alternate-colors)$(sep))
        $(foreach t,packages steps,./support/scripts/graph-build-time \
                                   --type=pie-$(t) --input=$(<) \
-                                  --output=$(O)/graphs/build.pie-$(t).$(_BR2_GRAPH_OUT) \
+                                  --output=$(O)/graphs/build.pie-$(t).$(BR_GRAPH_OUT) \
                                   $(if $(BR2_GRAPH_ALT),--alternate-colors)$(sep))
 
 graph-depends:
        @$(INSTALL) -d $(O)/graphs
        @cd "$(CONFIG_DIR)"; \
        $(TOPDIR)/support/scripts/graph-depends \
-       |dot -T$(_BR2_GRAPH_OUT) -o $(O)/graphs/$(@).$(_BR2_GRAPH_OUT)
+       |dot -T$(BR_GRAPH_OUT) -o $(O)/graphs/$(@).$(BR_GRAPH_OUT)
 
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
index 339c3ebc01724db2f38aee343ef8911bcd5557e0..b3a4c17cc30cd458d5944f114a67d38d157a2d86 100644 (file)
@@ -496,7 +496,7 @@ $(1)-graph-depends:
                        @$(INSTALL) -d $(O)/graphs
                        @cd "$(CONFIG_DIR)"; \
                        $(TOPDIR)/support/scripts/graph-depends $(1) \
-                       |dot -T$(_BR2_GRAPH_OUT) -o $(O)/graphs/$$(@).$(_BR2_GRAPH_OUT)
+                       |dot -T$(BR_GRAPH_OUT) -o $(O)/graphs/$$(@).$(BR_GRAPH_OUT)
 
 $(1)-dirclean:         $$($(2)_TARGET_DIRCLEAN)