gawk: bump to version 4.2.1
authorBaruch Siach <baruch@tkos.co.il>
Wed, 28 Mar 2018 22:12:01 +0000 (01:12 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 29 Mar 2018 16:11:07 +0000 (18:11 +0200)
Enable static build. gawk builds statically just fine. The shared
library check has been removed in 4.1.1.

Remove the symlink force hunk from the no-versioned patch. The only user
of LN is in the part that this patch disables.

Add license file hash.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gawk/0001-no-versioned.patch
package/gawk/Config.in
package/gawk/gawk.hash
package/gawk/gawk.mk

index 0c35088e8656882b40c8a90d7f6ab9f5391f7924..c5bbdddeb5efa0cf15b42529b10b1cf82253a470 100644 (file)
@@ -1,5 +1,4 @@
 Disabled versioned installation of binaries to save space.
-Also use symlinks where it's appropiate.
 
 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 [Gustavo: update for 4.1.2]
@@ -7,15 +6,6 @@ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 diff -Nura gawk-4.1.2.orig/Makefile.in gawk-4.1.2/Makefile.in
 --- gawk-4.1.2.orig/Makefile.in        2015-04-29 16:11:09.367925925 -0300
 +++ gawk-4.1.2/Makefile.in     2015-04-29 16:11:25.308466495 -0300
-@@ -554,7 +554,7 @@
- CLEANFILES = core core.*
- # We want hard links for install-exec-hook, below
--LN = ln
-+LN = $(LN_S)
- # For some make's, e.g. OpenBSD, that don't define this
- RM = rm -f
 @@ -1173,6 +1173,7 @@
  # (This is done universally, which may not always be right, but
  # there's no easy way to distinguish GNU from non-GNU systems.)
index a065243b7db199bcab852cca195aafe880b47e1a..e9cf4c5ff7746aea0f452c5ee5532adb34289f8b 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_GAWK
        bool "gawk"
        depends on BR2_USE_WCHAR
        depends on BR2_USE_MMU # fork()
-       depends on !BR2_STATIC_LIBS
        depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        help
          A special-purpose programming language which is data driven
@@ -11,7 +10,7 @@ config BR2_PACKAGE_GAWK
 
          http://www.gnu.org/software/gawk/
 
-comment "gawk needs a toolchain w/ wchar, dynamic library"
+comment "gawk needs a toolchain w/ wchar"
        depends on BR2_USE_MMU
-       depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS
+       depends on !BR2_USE_WCHAR
        depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
index e2c7806cc5d7c158bf83ded86d22a25f464bba2f..d8dd27c17c37c5516995e456dde780a88691cf5e 100644 (file)
@@ -1,2 +1,5 @@
 # Locally calculated after checking pgp signature
-sha256 53e184e2d0f90def9207860531802456322be091c7b48f23fdc79cda65adc266        gawk-4.1.4.tar.xz
+# https://ftp.gnu.org/gnu/gawk/gawk-4.2.1.tar.xz.sig
+sha256 d1119785e746d46a8209d28b2de404a57f983aa48670f4e225531d3bdc175551        gawk-4.2.1.tar.xz
+# Locally calculated
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903        COPYING
index a3a29273736152d18682dca6f012f1d1fb0dfc15..0779736882b585fbe397855ca371cc39ada62d6a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GAWK_VERSION = 4.1.4
+GAWK_VERSION = 4.2.1
 GAWK_SOURCE = gawk-$(GAWK_VERSION).tar.xz
 GAWK_SITE = $(BR2_GNU_MIRROR)/gawk
 GAWK_DEPENDENCIES = host-gawk
@@ -44,13 +44,5 @@ endef
 
 GAWK_POST_INSTALL_TARGET_HOOKS += GAWK_CREATE_SYMLINK
 
-# Assume we support shared libs
-# The check isn't cross-compile friendly and it's mandatory anyway
-define GAWK_DISABLE_SHARED_CHECK
-       $(SED) 's/ check-for-shared-lib-support//' $(@D)/extension/Makefile.in
-endef
-
-GAWK_POST_PATCH_HOOKS += GAWK_DISABLE_SHARED_CHECK
-
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))