Disabled versioned installation of binaries to save space.
-Also use symlinks where it's appropiate.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Gustavo: update for 4.1.2]
diff -Nura gawk-4.1.2.orig/Makefile.in gawk-4.1.2/Makefile.in
--- gawk-4.1.2.orig/Makefile.in 2015-04-29 16:11:09.367925925 -0300
+++ gawk-4.1.2/Makefile.in 2015-04-29 16:11:25.308466495 -0300
-@@ -554,7 +554,7 @@
- CLEANFILES = core core.*
-
- # We want hard links for install-exec-hook, below
--LN = ln
-+LN = $(LN_S)
-
- # For some make's, e.g. OpenBSD, that don't define this
- RM = rm -f
@@ -1173,6 +1173,7 @@
# (This is done universally, which may not always be right, but
# there's no easy way to distinguish GNU from non-GNU systems.)
bool "gawk"
depends on BR2_USE_WCHAR
depends on BR2_USE_MMU # fork()
- depends on !BR2_STATIC_LIBS
depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
help
A special-purpose programming language which is data driven
http://www.gnu.org/software/gawk/
-comment "gawk needs a toolchain w/ wchar, dynamic library"
+comment "gawk needs a toolchain w/ wchar"
depends on BR2_USE_MMU
- depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS
+ depends on !BR2_USE_WCHAR
depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
# Locally calculated after checking pgp signature
-sha256 53e184e2d0f90def9207860531802456322be091c7b48f23fdc79cda65adc266 gawk-4.1.4.tar.xz
+# https://ftp.gnu.org/gnu/gawk/gawk-4.2.1.tar.xz.sig
+sha256 d1119785e746d46a8209d28b2de404a57f983aa48670f4e225531d3bdc175551 gawk-4.2.1.tar.xz
+# Locally calculated
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING
#
################################################################################
-GAWK_VERSION = 4.1.4
+GAWK_VERSION = 4.2.1
GAWK_SOURCE = gawk-$(GAWK_VERSION).tar.xz
GAWK_SITE = $(BR2_GNU_MIRROR)/gawk
GAWK_DEPENDENCIES = host-gawk
GAWK_POST_INSTALL_TARGET_HOOKS += GAWK_CREATE_SYMLINK
-# Assume we support shared libs
-# The check isn't cross-compile friendly and it's mandatory anyway
-define GAWK_DISABLE_SHARED_CHECK
- $(SED) 's/ check-for-shared-lib-support//' $(@D)/extension/Makefile.in
-endef
-
-GAWK_POST_PATCH_HOOKS += GAWK_DISABLE_SHARED_CHECK
-
$(eval $(autotools-package))
$(eval $(host-autotools-package))