arm-trusted-firmware: replace mkimage invocation with MKIMAGE
authorDanomi Manchego <danomimanchego123@gmail.com>
Wed, 24 Oct 2018 02:43:11 +0000 (22:43 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 26 Oct 2018 19:26:27 +0000 (21:26 +0200)
We already use $(MKIMAGE) instead of $(HOST_DIR)/bin/mkimage in xvisor, linux,
and cpio; use it here too.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/arm-trusted-firmware/arm-trusted-firmware.mk

index 19f7c4c80a696e5a1e662e756d8e25d615eb2035..f353d56448dbee421c103376b66fb857c984d55d 100644 (file)
@@ -80,7 +80,7 @@ define ARM_TRUSTED_FIRMWARE_BL31_UBOOT_BUILD
 # Get the entry point address from the elf.
        BASE_ADDR=$$($(TARGET_READELF) -h $(ARM_TRUSTED_FIRMWARE_IMG_DIR)/bl31/bl31.elf | \
                     sed -r '/^  Entry point address:\s*(.*)/!d; s//\1/') && \
-       $(HOST_DIR)/bin/mkimage \
+       $(MKIMAGE) \
                -A arm64 -O arm-trusted-firmware -C none \
                -a $${BASE_ADDR} -e $${BASE_ADDR} \
                -d $(ARM_TRUSTED_FIRMWARE_IMG_DIR)/bl31.bin \