package/mpv: add libv4l support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 19 Jan 2020 09:51:02 +0000 (10:51 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 19 Jan 2020 22:10:05 +0000 (23:10 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpv/mpv.mk

index 2150f7e9aac57b09eb8e01e14d37f831f9c9f820..8619de5a8e4d1f89f71b6ac02ac0dabb27ef5417 100644 (file)
@@ -23,7 +23,6 @@ MPV_CONF_OPTS = \
        --disable-cocoa \
        --disable-coreaudio \
        --disable-cuda-hwaccel \
-       --disable-libv4l2 \
        --disable-opensles \
        --disable-rsound \
        --disable-rubberband \
@@ -129,6 +128,16 @@ else
 MPV_CONF_OPTS += --disable-drm
 endif
 
+# libv4l
+ifeq ($(BR2_PACKAGE_LIBV4L),y)
+MPV_CONF_OPTS += \
+       --enable-libv4l2 \
+       --enable-tv
+MPV_DEPENDENCIES += libv4l
+else
+MPV_CONF_OPTS += --disable-libv4l2
+endif
+
 # libvdpau
 ifeq ($(BR2_PACKAGE_LIBVDPAU),y)
 MPV_CONF_OPTS += --enable-vdpau