package/mutt: add gpgme optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 30 Jan 2021 13:42:44 +0000 (14:42 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 30 Jan 2021 21:18:53 +0000 (22:18 +0100)
gpgme is supported since 2005 and
https://gitlab.com/muttmua/mutt/-/commit/4bb5db92a89158cc45c3480f2be62d0b435c9a4e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mutt/mutt.mk

index c2188cebea6ae1ffecc902eaec9566496aff5926..9557983a0796f0a110672d7fd7c81a3c6d4891ed 100644 (file)
@@ -36,6 +36,15 @@ else
 MUTT_CONF_OPTS += --without-idn --without-idn2
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGPGME),y)
+MUTT_DEPENDENCIES += libgpgme
+MUTT_CONF_OPTS += \
+       --enable-gpgme \
+       --with-gpgme-prefix=$(STAGING_DIR)/usr
+else
+MUTT_CONF_OPTS += --disable-gpgme
+endif
+
 ifeq ($(BR2_PACKAGE_MUTT_IMAP),y)
 MUTT_CONF_OPTS += --enable-imap
 else