python-serial-asyncio: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Mon, 22 Oct 2018 09:16:51 +0000 (17:16 +0800)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 23 Oct 2018 14:35:44 +0000 (16:35 +0200)
asyncio extension package for pyserial

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-serial-asyncio/Config.in [new file with mode: 0644]
package/python-serial-asyncio/python-serial-asyncio.hash [new file with mode: 0644]
package/python-serial-asyncio/python-serial-asyncio.mk [new file with mode: 0644]

index 6d2a73ff1b85be2a39131344c6632aa6357b9653..710cde6691e108115b1789d9e040103484c01185 100644 (file)
@@ -1008,6 +1008,7 @@ menu "External python modules"
        source "package/python-see/Config.in"
        source "package/python-semver/Config.in"
        source "package/python-serial/Config.in"
+       source "package/python-serial-asyncio/Config.in"
        source "package/python-service-identity/Config.in"
        source "package/python-setproctitle/Config.in"
        source "package/python-setuptools/Config.in"
diff --git a/package/python-serial-asyncio/Config.in b/package/python-serial-asyncio/Config.in
new file mode 100644 (file)
index 0000000..5520b72
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_SERIAL_ASYNCIO
+       bool "python-serial-asyncio"
+       depends on BR2_PACKAGE_PYTHON3
+       select BR2_PACKAGE_PYTHON_SERIAL
+       help
+         asyncio extension package for pyserial.
+
+         https://github.com/pyserial/pyserial-asyncio
diff --git a/package/python-serial-asyncio/python-serial-asyncio.hash b/package/python-serial-asyncio/python-serial-asyncio.hash
new file mode 100644 (file)
index 0000000..268c7d8
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/pyserial-asyncio/json
+md5     67244fdc11cc31cf0ebf675c271c71d8  pyserial-asyncio-0.4.tar.gz
+sha256  c40677a8874d8c24d4423a97498746de776f6dbcd0efbb8fa43dcf011a589aee  pyserial-asyncio-0.4.tar.gz
+# Locally computed sha256 checksums
+sha256 f8ded3a7460d3b2850b0cf673e986c70e9d997fd0732d8ab3f3c84f1f191087d  LICENSE.txt
diff --git a/package/python-serial-asyncio/python-serial-asyncio.mk b/package/python-serial-asyncio/python-serial-asyncio.mk
new file mode 100644 (file)
index 0000000..39c3476
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-serial-asyncio
+#
+################################################################################
+
+PYTHON_SERIAL_ASYNCIO_VERSION = 0.4
+PYTHON_SERIAL_ASYNCIO_SOURCE = pyserial-asyncio-$(PYTHON_SERIAL_ASYNCIO_VERSION).tar.gz
+PYTHON_SERIAL_ASYNCIO_SITE = https://files.pythonhosted.org/packages/41/3f/e26f71269cbc0890a527a736d9afc5c0d5838a2c188be680558d635b7dc2
+PYTHON_SERIAL_ASYNCIO_LICENSE = BSD-3-Clause
+PYTHON_SERIAL_ASYNCIO_LICENSE_FILES = LICENSE.txt
+PYTHON_SERIAL_ASYNCIO_SETUP_TYPE = setuptools
+
+$(eval $(python-package))