Install DTB as part of images install command
authorReuben Dowle <reuben.dowle@4rf.com>
Wed, 27 Mar 2013 23:01:15 +0000 (23:01 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Aug 2013 15:39:43 +0000 (17:39 +0200)
When installing DTB to the images directory, do this as part of the image
install commands rather than the target install commands.

Signed-off-by: Reuben Dowle <reuben.dowle@4rf.com.az>
Acked-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index fc379ec49902cae2baf7807a5e0dbdfea70d62d7..578d535c3c1053a83f6ad249a9b5d647bac0892e 100644 (file)
@@ -265,11 +265,11 @@ endef
 
 define LINUX_INSTALL_IMAGES_CMDS
        cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
+       $(LINUX_INSTALL_DTB)
 endef
 
 define LINUX_INSTALL_TARGET_CMDS
        $(LINUX_INSTALL_KERNEL_IMAGE_TO_TARGET)
-       $(LINUX_INSTALL_DTB)
        # Install modules and remove symbolic links pointing to build
        # directories, not relevant on the target
        @if grep -q "CONFIG_MODULES=y" $(@D)/.config; then      \