gnutls: make crywrap a tools option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 5 Jun 2013 04:58:17 +0000 (04:58 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 5 Jun 2013 21:06:44 +0000 (23:06 +0200)
crywrap now needs wchar support so just build it when tools are enabled.
It's also a tool so it belongs there anyway.
Fixes:
http://autobuild.buildroot.net/results/418/418ce71eecc1db725e3b3f092131a01cb1666a60/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gnutls/gnutls.mk

index 3089979a06c2a38d06da7fad657a95f7ead734a0..43ec9777de78eea0ed1d96c407c6e7201cd468d3 100644 (file)
@@ -37,6 +37,11 @@ GNUTLS_CONF_OPT += --with-regex-header=pcreposix.h \
        --with-libregex-cflags="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --cflags`" \
        --with-libregex-libs="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --libs`"
 
+# Consider crywrap as part of tools because it needs WCHAR, and it's so too
+ifeq ($(BR2_PACKAGE_GNUTLS_TOOLS),)
+       GNUTLS_CONF_OPT += --disable-crywrap
+endif
+
 # libidn support for nommu must exclude the crywrap wrapper (uses fork)
 GNUTLS_CONF_OPT += $(if $(BR2_USE_MMU),,--disable-crywrap)
 GNUTLS_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBIDN),libidn)