fs/ext2: deprecate BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES option
authorSamuel Martin <s.martin49@gmail.com>
Tue, 4 Jul 2017 14:47:25 +0000 (16:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 22:35:00 +0000 (00:35 +0200)
Soon, the ext{2,3,4} rootfs image will no longer be generated with
genext2fs, but using mke2fs instead which has no support for the extra
inode number option.

So, deprecate the BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES option and
recommend, in lieu, to set the total inode number, taking account of
the extra ones if needed.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Cc: Sébastien Szymanski <sebastien.szymanski@armadeus.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
fs/ext2/Config.in
fs/ext2/ext2.mk

index f1a1b8ad7cee423db1dd080a00ad02fa0e8f79b6..2b88ddf8c1fea9a878ec6be8c4dba02de73c1130 100644 (file)
@@ -145,6 +145,21 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.08"
 
+config BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES
+       int "ext2 extra inodes has been removed" if BR2_TARGET_ROOTFS_EXT2_INODES = 0
+       default 0
+       help
+         Buildroot now uses mkfs.ext2/3/4 to generate ext2/3/4
+         images. It now automatically selects the number of inodes
+         based on the image size. The extra number of inodes can no
+         longer be provided; instead, provide the total number of
+         inodes needed in BR2_TARGET_ROOTFS_EXT2_INODES.
+
+config BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES_WRAP
+       bool
+       default y if BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES != 0
+       select BR2_LEGACY
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CDXAPARSE
        bool "cdxaparse removed"
        select BR2_LEGACY
index 6f16dde17f93636dcc18751d67928884a747c43d..ec1b5f2c55a52291b857450746afe3a3140ad939 100644 (file)
@@ -55,14 +55,6 @@ config BR2_TARGET_ROOTFS_EXT2_INODES
        int "exact number of inodes (leave at 0 for auto calculation)"
        default 0
 
-config BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES
-       int "extra inodes" if BR2_TARGET_ROOTFS_EXT2_INODES = 0
-       default 0
-       help
-         Enter here the number of extra free inodes you want on
-         your filesystem. By default, Buildroot will not leave
-         many free inodes.
-
 config BR2_TARGET_ROOTFS_EXT2_RESBLKS
        int "reserved blocks percentage"
        default 5
index 0d5fc7f118737242d6a3ad3db64aa57292896888..8a648dd66c73a3aef175f1b8a7bf15b30ea97cc5 100644 (file)
@@ -15,7 +15,6 @@ EXT2_OPTS = \
        -B 1024 \
        -b $(BR2_TARGET_ROOTFS_EXT2_BLOCKS) \
        -i $(BR2_TARGET_ROOTFS_EXT2_INODES) \
-       -I $(BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES) \
        -r $(BR2_TARGET_ROOTFS_EXT2_RESBLKS) \
        -l "$(EXT2_LABEL)"