xerces: make sure to use the cross-compiled curl
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 16:25:56 +0000 (17:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 17:46:51 +0000 (18:46 +0100)
When curl support is enabled in xerces, and a host curl is available
on the system, it might try to use it, so this patch adds --with-curl=
to the configure options to explicitly indicate where is the curl
library to use.

Should fix:

  http://autobuild.buildroot.org/results/c3c/c3c6be45d0f764fb931a46dbf1509ccf2916ecbf/

  (We were not able to reproduce specifically this problem, but
  another similar problem, where curl was detected, but considered as
  non-working because of the compilation failure of a test program.)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/xerces/xerces.mk

index 36955e3671635127099035358ef8c518633785c9..9b2bb81ec1bc17e7c5cfc3ea9108cadb91d59eaf 100644 (file)
@@ -20,7 +20,7 @@ XERCES_DEPENDENCIES += libiconv
 endif
 
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
-XERCES_CONF_OPTS += --enable-netaccessor-curl
+XERCES_CONF_OPTS += --enable-netaccessor-curl --with-curl=$(STAGING_DIR)/usr/lib
 XERCES_DEPENDENCIES += libcurl
 else
 XERCES_CONF_OPTS += --disable-network