ltrace: bump to version 0.7.3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 17 Sep 2013 17:39:34 +0000 (14:39 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Sep 2013 18:44:30 +0000 (20:44 +0200)
Now with proper mips support!

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ltrace/Config.in
package/ltrace/ltrace-01-events.patch [new file with mode: 0644]
package/ltrace/ltrace-events.patch [deleted file]
package/ltrace/ltrace-uclibc.patch [deleted file]
package/ltrace/ltrace.mk

index 4f1c42f7acd5cd89bf63d17012b4917e6961bf7c..943af8dad89dded3964af519091d77f51a8824be 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LTRACE
        bool "ltrace"
-       depends on !(BR2_avr32 || BR2_mips || BR2_sh || BR2_sh64 || BR2_xtensa || BR2_aarch64 || BR2_arc)
+       depends on !(BR2_avr32 || BR2_sh || BR2_sh64 || BR2_xtensa || BR2_aarch64 || BR2_arc)
        select BR2_PACKAGE_LIBELF
        help
          Debugging program which runs a specified command until it exits.
@@ -8,4 +8,4 @@ config BR2_PACKAGE_LTRACE
          the dynamic library calls which are called by the executed
          process and the signals received by that process.
 
-         http://packages.debian.org/unstable/utils/ltrace.html
+         http://ltrace.org
diff --git a/package/ltrace/ltrace-01-events.patch b/package/ltrace/ltrace-01-events.patch
new file mode 100644 (file)
index 0000000..f3699a1
--- /dev/null
@@ -0,0 +1,47 @@
+[PATCH] events.c: add similar system headers workaround as trace.c
+
+Needed for E.G. powerpc on uClibc.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ sysdeps/linux-gnu/events.c |   27 +++++++++++++++++++++++++++
+ 1 file changed, 27 insertions(+)
+
+Index: ltrace-0.6.0/sysdeps/linux-gnu/events.c
+===================================================================
+--- ltrace-0.6.0.orig/sysdeps/linux-gnu/events.c
++++ ltrace-0.6.0/sysdeps/linux-gnu/events.c
+@@ -11,6 +11,33 @@
+ #include "common.h"
++/* If the system headers did not provide the constants, hard-code the normal
++   values.  */
++#ifndef PTRACE_EVENT_FORK
++
++#define PTRACE_OLDSETOPTIONS    21
++#define PTRACE_SETOPTIONS       0x4200
++#define PTRACE_GETEVENTMSG      0x4201
++
++/* options set using PTRACE_SETOPTIONS */
++#define PTRACE_O_TRACESYSGOOD   0x00000001
++#define PTRACE_O_TRACEFORK      0x00000002
++#define PTRACE_O_TRACEVFORK     0x00000004
++#define PTRACE_O_TRACECLONE     0x00000008
++#define PTRACE_O_TRACEEXEC      0x00000010
++#define PTRACE_O_TRACEVFORKDONE 0x00000020
++#define PTRACE_O_TRACEEXIT      0x00000040
++
++/* Wait extended result codes for the above trace options.  */
++#define PTRACE_EVENT_FORK       1
++#define PTRACE_EVENT_VFORK      2
++#define PTRACE_EVENT_CLONE      3
++#define PTRACE_EVENT_EXEC       4
++#define PTRACE_EVENT_VFORK_DONE 5
++#define PTRACE_EVENT_EXIT       6
++
++#endif /* PTRACE_EVENT_FORK */
++
+ static Event event;
+ Event *
diff --git a/package/ltrace/ltrace-events.patch b/package/ltrace/ltrace-events.patch
deleted file mode 100644 (file)
index f3699a1..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-[PATCH] events.c: add similar system headers workaround as trace.c
-
-Needed for E.G. powerpc on uClibc.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- sysdeps/linux-gnu/events.c |   27 +++++++++++++++++++++++++++
- 1 file changed, 27 insertions(+)
-
-Index: ltrace-0.6.0/sysdeps/linux-gnu/events.c
-===================================================================
---- ltrace-0.6.0.orig/sysdeps/linux-gnu/events.c
-+++ ltrace-0.6.0/sysdeps/linux-gnu/events.c
-@@ -11,6 +11,33 @@
- #include "common.h"
-+/* If the system headers did not provide the constants, hard-code the normal
-+   values.  */
-+#ifndef PTRACE_EVENT_FORK
-+
-+#define PTRACE_OLDSETOPTIONS    21
-+#define PTRACE_SETOPTIONS       0x4200
-+#define PTRACE_GETEVENTMSG      0x4201
-+
-+/* options set using PTRACE_SETOPTIONS */
-+#define PTRACE_O_TRACESYSGOOD   0x00000001
-+#define PTRACE_O_TRACEFORK      0x00000002
-+#define PTRACE_O_TRACEVFORK     0x00000004
-+#define PTRACE_O_TRACECLONE     0x00000008
-+#define PTRACE_O_TRACEEXEC      0x00000010
-+#define PTRACE_O_TRACEVFORKDONE 0x00000020
-+#define PTRACE_O_TRACEEXIT      0x00000040
-+
-+/* Wait extended result codes for the above trace options.  */
-+#define PTRACE_EVENT_FORK       1
-+#define PTRACE_EVENT_VFORK      2
-+#define PTRACE_EVENT_CLONE      3
-+#define PTRACE_EVENT_EXEC       4
-+#define PTRACE_EVENT_VFORK_DONE 5
-+#define PTRACE_EVENT_EXIT       6
-+
-+#endif /* PTRACE_EVENT_FORK */
-+
- static Event event;
- Event *
diff --git a/package/ltrace/ltrace-uclibc.patch b/package/ltrace/ltrace-uclibc.patch
deleted file mode 100644 (file)
index c1041fb..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-[PATCH] configure.ac: Recognize linux-uclibc as well
-
-Ltrace works on uClibc as well as on glibc, so accept it.
-
-[Gustavo: update for ltrace 0.7.1]
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura ltrace-0.7.1.orig/configure.ac ltrace-0.7.1/configure.ac
---- ltrace-0.7.1.orig/configure.ac     2012-12-03 09:02:32.995352741 -0300
-+++ ltrace-0.7.1/configure.ac  2012-12-03 09:02:56.579096389 -0300
-@@ -32,7 +32,7 @@
- AC_CANONICAL_HOST
- case "${host_os}" in
--    linux-gnu*)       HOST_OS="linux-gnu" ;;
-+    linux-gnu* | linux-uclibc*)       HOST_OS="linux-gnu" ;;
-     *)                AC_MSG_ERROR([unkown host-os ${host_os}]) ;;
- esac
- AC_SUBST(HOST_OS)
index 0ea8ff3272b738d9f4f5e6ebff96f6fa86d92c30..b42c2523325918187523605aedb01fe741c740a5 100644 (file)
@@ -4,22 +4,14 @@
 #
 ################################################################################
 
-LTRACE_VERSION = 0.7.2
-LTRACE_SITE = http://alioth.debian.org/frs/download.php/file/3848
+LTRACE_VERSION = 0.7.3
+LTRACE_SITE = http://alioth.debian.org/frs/download.php/file/3947
 LTRACE_SOURCE = ltrace-$(LTRACE_VERSION).tar.bz2
 LTRACE_DEPENDENCIES = libelf
-LTRACE_AUTORECONF = YES
 LTRACE_CONF_OPT = --disable-werror
 LTRACE_LICENSE = GPLv2
 LTRACE_LICENSE_FILES = COPYING
 
-# symlink missing from tarball
-define LTRACE_MIPS_SYMLINK
-       cd $(@D)/sysdeps/linux-gnu; ln -sf mipsel mips
-endef
-
-LTRACE_POST_EXTRACT_HOOKS += LTRACE_MIPS_SYMLINK
-
 # ltrace can use libunwind only if libc has backtrace() support
 # We don't normally do so for uClibc and we can't know if it's external
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)