package/libnss: bump to version 3.49.1
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Mon, 13 Jan 2020 19:09:59 +0000 (20:09 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2020 20:17:07 +0000 (21:17 +0100)
Drop 1 upstreamed patch.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libnss/0001-Bug-1602743-Fix-PowerPc-build-sys-auxv.h-failure.patch [new file with mode: 0644]
package/libnss/0001-add-zlib-include-dir-variable.patch [deleted file]
package/libnss/0002-Bug-1602743-Fix-PowerPc-build-sys-auxv.h-failure.patch [deleted file]
package/libnss/libnss.hash
package/libnss/libnss.mk

diff --git a/package/libnss/0001-Bug-1602743-Fix-PowerPc-build-sys-auxv.h-failure.patch b/package/libnss/0001-Bug-1602743-Fix-PowerPc-build-sys-auxv.h-failure.patch
new file mode 100644 (file)
index 0000000..c8f12d7
--- /dev/null
@@ -0,0 +1,40 @@
+From efe0fd875c80ff6e3a05db6c5e15b07c173530a6 Mon Sep 17 00:00:00 2001
+From: Giulio Benetti <giulio.benetti@benettiengineering.com>
+Date: Tue, 10 Dec 2019 13:06:01 +0100
+Subject: [PATCH] Bug 1602743 - Fix PowerPc build sys/auxv.h failure
+
+Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
+---
+ nss/lib/freebl/blinit.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/nss/lib/freebl/blinit.c b/nss/lib/freebl/blinit.c
+index 959109b60..f0654595d 100644
+--- a/nss/lib/freebl/blinit.c
++++ b/nss/lib/freebl/blinit.c
+@@ -357,7 +357,9 @@ ppc_crypto_support()
+ #if defined(__powerpc__)
++#if (__has_include(<sys/auxv.h>))
+ #include <sys/auxv.h>
++#endif
+ // Defines from cputable.h in Linux kernel - PPC, letting us build on older kernels
+ #ifndef PPC_FEATURE2_VEC_CRYPTO
+@@ -368,8 +370,11 @@ static void
+ CheckPPCSupport()
+ {
+     char *disable_hw_crypto = PR_GetEnvSecure("NSS_DISABLE_PPC_GHASH");
++    long hwcaps = 0;
+-    long hwcaps = getauxval(AT_HWCAP2);
++#if (__has_include(<sys/auxv.h>))
++    hwcaps = getauxval(AT_HWCAP2);
++#endif
+     ppc_crypto_support_ = hwcaps & PPC_FEATURE2_VEC_CRYPTO && disable_hw_crypto == NULL;
+ }
+-- 
+2.20.1
+
diff --git a/package/libnss/0001-add-zlib-include-dir-variable.patch b/package/libnss/0001-add-zlib-include-dir-variable.patch
deleted file mode 100644 (file)
index cd0bdee..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-Add ZLIB_INCLUDE_DIR variable
-
-On Linux platform[1], the build system forces to use zlib from the
-system instead of compiling the one located intree.
-
-The following error is raised when the zlib header is installed
-somewhere else than in the default system include path:
-
-       ssl3con.c:39:18: fatal error: zlib.h: No such file or directory
-        #include "zlib.h"
-
-The same trick setup for sqlite include directory is reproduced for
-zlib. The build system disallows in any manner to give arguments to the
-compiler explicity.
-
-The variable ZLIB_INCLUDE_DIR point to the directory where the zlib
-header is located.
-
-[1]: https://hg.mozilla.org/projects/nss/file/NSS_3_33_BRANCH/coreconf/Linux.mk#l180
-[2]: https://hg.mozilla.org/projects/nss/file/NSS_3_33_BRANCH/lib/softoken/manifest.mn#l17
-
-Signed-off-by: GaĆ«l PORTAY <gael.portay@savoirfairelinux.com>
-
---- libnss-3.33.orig/nss/lib/ssl/manifest.mn   2017-09-20 02:47:27.000000000 -0400
-+++ libnss-3.33/nss/lib/ssl/manifest.mn        2018-02-16 16:45:41.512709898 -0500
-@@ -6,6 +6,10 @@
- # DEFINES = -DTRACE
-+ifdef ZLIB_INCLUDE_DIR
-+INCLUDES += -I$(ZLIB_INCLUDE_DIR)
-+endif
-+
- EXPORTS = \
-         ssl.h \
-         sslt.h \
---- host-libnss-3.33.orig/nss/cmd/signtool/manifest.mn.orig    2018-02-16 17:08:58.474777871 -0500
-+++ host-libnss-3.33/nss/cmd/signtool/manifest.mn      2018-02-16 17:09:22.603710963 -0500
-@@ -6,6 +6,10 @@
- MODULE = nss
-+ifdef ZLIB_INCLUDE_DIR
-+INCLUDES += -I$(ZLIB_INCLUDE_DIR)
-+endif
-+
- EXPORTS = 
- CSRCS = signtool.c            \
diff --git a/package/libnss/0002-Bug-1602743-Fix-PowerPc-build-sys-auxv.h-failure.patch b/package/libnss/0002-Bug-1602743-Fix-PowerPc-build-sys-auxv.h-failure.patch
deleted file mode 100644 (file)
index c8f12d7..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From efe0fd875c80ff6e3a05db6c5e15b07c173530a6 Mon Sep 17 00:00:00 2001
-From: Giulio Benetti <giulio.benetti@benettiengineering.com>
-Date: Tue, 10 Dec 2019 13:06:01 +0100
-Subject: [PATCH] Bug 1602743 - Fix PowerPc build sys/auxv.h failure
-
-Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
----
- nss/lib/freebl/blinit.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/nss/lib/freebl/blinit.c b/nss/lib/freebl/blinit.c
-index 959109b60..f0654595d 100644
---- a/nss/lib/freebl/blinit.c
-+++ b/nss/lib/freebl/blinit.c
-@@ -357,7 +357,9 @@ ppc_crypto_support()
- #if defined(__powerpc__)
-+#if (__has_include(<sys/auxv.h>))
- #include <sys/auxv.h>
-+#endif
- // Defines from cputable.h in Linux kernel - PPC, letting us build on older kernels
- #ifndef PPC_FEATURE2_VEC_CRYPTO
-@@ -368,8 +370,11 @@ static void
- CheckPPCSupport()
- {
-     char *disable_hw_crypto = PR_GetEnvSecure("NSS_DISABLE_PPC_GHASH");
-+    long hwcaps = 0;
--    long hwcaps = getauxval(AT_HWCAP2);
-+#if (__has_include(<sys/auxv.h>))
-+    hwcaps = getauxval(AT_HWCAP2);
-+#endif
-     ppc_crypto_support_ = hwcaps & PPC_FEATURE2_VEC_CRYPTO && disable_hw_crypto == NULL;
- }
--- 
-2.20.1
-
index d87ad8e3abec2f7106e2eee7784582eb7d8ad698..01098df99a69f455605ecf2cadd829a7fcc288f5 100644 (file)
@@ -1,4 +1,4 @@
 # From https://ftp.mozilla.org/pub/security/nss/releases/NSS_3_48_RTM/src/SHA256SUMS
-sha256 6738094dc4fd63061118a122bf3999a64fe8c7117fc52f6e81c2279181bde71d  nss-3.49.tar.gz
+sha256 d9aa42e49e02bb0dc0a2f164604cfc718e11a2a06ddb266cd676376ac21b026e  nss-3.49.1.tar.gz
 # Locally calculated
 sha256 a20c1a32d1f8102432360b42e932869f7c11c7cdbacf9cac554c422132af47f4  nss/COPYING
index 61950ade25ce2a5e5d34290d90364eccbeb9695d..d7d3cda86be7bd65a3db6c3956aeefcf344c78f9 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBNSS_VERSION = 3.49
+LIBNSS_VERSION = 3.49.1
 LIBNSS_SOURCE = nss-$(LIBNSS_VERSION).tar.gz
 LIBNSS_SITE = https://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_$(subst .,_,$(LIBNSS_VERSION))_RTM/src
 LIBNSS_DISTDIR = dist