package/popperjs: new package
authorJoeri Barbarien <joeri.barbarien@nokia.com>
Tue, 8 Dec 2020 18:16:38 +0000 (19:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 2 Jan 2021 11:26:18 +0000 (12:26 +0100)
Signed-off-by: Joeri Barbarien <joeri.barbarien@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/popperjs/Config.in [new file with mode: 0644]
package/popperjs/popperjs.hash [new file with mode: 0644]
package/popperjs/popperjs.mk [new file with mode: 0644]

index 6a0c2ed7b9174bc33063d73e1f1af7077db272e8..a618b11d98cb42cc44c6f52524065f4130770fe0 100644 (file)
@@ -2545,6 +2545,7 @@ F:        package/perl-net-ssh2/
 F:     package/perl-net-telnet/
 F:     package/perl-path-class/
 F:     package/pigz/
+F:     package/popperjs/
 F:     package/xenomai/
 F:     support/scripts/size-stats
 F:     support/testing/tests/package/test_perl_lwp_protocol_https.py
index 6451ad4b4742245195bd758c7c406582f5855778..9f55133c127ef55c8886898726fb68a5fdff1f84 100644 (file)
@@ -1603,6 +1603,7 @@ endif
        source "package/json-javascript/Config.in"
        source "package/jszip/Config.in"
        source "package/openlayers/Config.in"
+       source "package/popperjs/Config.in"
        source "package/spidermonkey/Config.in"
        source "package/vuejs/Config.in"
 endmenu
diff --git a/package/popperjs/Config.in b/package/popperjs/Config.in
new file mode 100644 (file)
index 0000000..eae9631
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_POPPERJS
+       bool "popperjs"
+       help
+         Popper.js, a JavaScript Tooltip & Popover Positioning Engine.
+
+         https://popper.js.org
diff --git a/package/popperjs/popperjs.hash b/package/popperjs/popperjs.hash
new file mode 100644 (file)
index 0000000..d9cdabc
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed:
+sha256 83eecef51d10826faca2cd5cabb344e0bef6d4127d7e728db9e4d8308b7b15d1  popperjs-1.16.0.tar.gz
+sha256 2961310ed05cd9373a08b8191c071425a7fede0ca5d807ca38fa5f5f61c5b834  LICENSE.md
diff --git a/package/popperjs/popperjs.mk b/package/popperjs/popperjs.mk
new file mode 100644 (file)
index 0000000..c5df302
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# popperjs
+#
+################################################################################
+
+POPPERJS_VERSION = 1.16.0
+POPPERJS_SITE = $(call github,popperjs,popper-core,v$(POPPERJS_VERSION))
+POPPERJS_LICENSE = MIT
+POPPERJS_LICENSE_FILES = LICENSE.md
+
+define POPPERJS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/dist/umd/popper.min.js \
+               $(TARGET_DIR)/var/www/popperjs/js/popper.min.js
+       $(INSTALL) -m 0644 -D $(@D)/dist/umd/popper-utils.min.js \
+               $(TARGET_DIR)/var/www/popperjs/js/popper-utils.min.js
+endef
+
+$(eval $(generic-package))