package/mpd: add openal optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Aug 2020 16:30:26 +0000 (18:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 14 Aug 2020 20:49:24 +0000 (22:49 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 1b3ab8fa5d3d7da94ae68a36fb3cf93a8be08081..791fb0f54af68d4bbfae1d1fb2381ea3bb3a73ad 100644 (file)
@@ -286,6 +286,18 @@ comment "jack support needs a toolchain w/ dynamic library"
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on BR2_STATIC_LIBS
 
+config BR2_PACKAGE_MPD_OPENAL
+       bool "openal"
+       depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
+       depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
+       select BR2_PACKAGE_OPENAL
+       help
+         Enable OpenAL output support.
+
+comment "openal support needs a toolchain w/ NPTL"
+       depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
+       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL
+
 config BR2_PACKAGE_MPD_OSS
        bool "oss"
        help
index b8df04f08405f38902a4afcb3c593b078ca28174..a3b90aa55f6903363e6ada2109e175253aa3e79c 100644 (file)
@@ -200,6 +200,13 @@ else
 MPD_CONF_OPTS += -Dneighbor=false
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_OPENAL),y)
+MPD_DEPENDENCIES += openal
+MPD_CONF_OPTS += -Dopenal=enabled
+else
+MPD_CONF_OPTS += -Dopenal=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_OPUS),y)
 MPD_DEPENDENCIES += opus libogg
 MPD_CONF_OPTS += -Dopus=enabled