Makefile.autotools.in: use TARGET_PATH for compile step
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Mar 2009 13:48:35 +0000 (13:48 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Mar 2009 13:48:35 +0000 (13:48 -0000)
This ensures that the correct build tools are found rather than the host
versions (glib-genmarshal, ..)

package/Makefile.autotools.in

index b8abd73f36d4f93bf27f12a70e83d4be0c404ada..3c01837316d019896731f86b1eebebcd4f043328 100644 (file)
@@ -259,7 +259,7 @@ $(BUILD_DIR)/%/.stamp_configured:
 # Build
 $(BUILD_DIR)/%/.stamp_built:
        $(call MESSAGE,"Building")
-       $($(PKG)_MAKE_ENV) $($(PKG)_MAKE) $($(PKG)_MAKE_OPT) -C $(@D)/$($(PKG)_SUBDIR)
+       PATH=$(TARGET_PATH) $($(PKG)_MAKE_ENV) $($(PKG)_MAKE) $($(PKG)_MAKE_OPT) -C $(@D)/$($(PKG)_SUBDIR)
        $(Q)touch $@
 
 # Install to staging dir