kconfig infra: support built-in config files
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Tue, 3 Feb 2015 14:21:41 +0000 (15:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Feb 2015 15:32:23 +0000 (16:32 +0100)
When the configuration file of a package is located inside of the
package sources, a make dependency can only be expressed after the
package has been extracted (and patched).

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: "Yann E. Morin" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index ec58d69f55ee181e937d39e778d19b6da74179ed..ef724e595fdec23aac587248dcd144d5027cdbfc 100644 (file)
@@ -41,9 +41,13 @@ ifndef $(2)_KCONFIG_FILE
 $$(error Internal error: no value specified for $(2)_KCONFIG_FILE)
 endif
 
+# The config file could be in-tree, so before depending on it the package should
+# be extracted (and patched) first
+$$($(2)_KCONFIG_FILE): | $(1)-patch
+
 # The .config file is obtained by copying it from the specified source
 # configuration file, after the package has been patched.
-$$($(2)_DIR)/.config: $$($(2)_KCONFIG_FILE) | $(1)-patch
+$$($(2)_DIR)/.config: $$($(2)_KCONFIG_FILE)
        $$(INSTALL) -m 0644 $$($(2)_KCONFIG_FILE) $$($(2)_DIR)/.config
 
 # In order to get a usable, consistent configuration, some fixup may be needed.