links : convert to autotools infrastructure & bump to 1.01pre1-no-ssl
authorcmchao <cmchao@gmail.com>
Wed, 16 Jun 2010 11:47:06 +0000 (19:47 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 24 Jun 2010 11:51:07 +0000 (13:51 +0200)
Changes by Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

 * Installation to target is the default behaviour
 * No installation to staging is the default behaviour
 * Stripping is done globally
 * Remove incorrect cleaning rules

Signed-off-by: cmchao <cmchao@gmail.com>
package/links/links-1.01pre1-no-ssl-largefile.patch [new file with mode: 0644]
package/links/links.mk

diff --git a/package/links/links-1.01pre1-no-ssl-largefile.patch b/package/links/links-1.01pre1-no-ssl-largefile.patch
new file mode 100644 (file)
index 0000000..f3143cb
--- /dev/null
@@ -0,0 +1,22 @@
+Index: links-1.01pre1-no-ssl/links.h
+===================================================================
+--- links-1.01pre1-no-ssl.orig/links.h 2010-06-21 00:39:10.000000000 +0200
++++ links-1.01pre1-no-ssl/links.h      2010-06-21 00:39:52.000000000 +0200
+@@ -2,6 +2,9 @@
+ #define __EXTENSIONS__
+ #endif
++#include <features.h>
++/* uclibc without largefile support #errors on _FILE_OFFSET_BITS=64 */
++#if !(defined(__UCLIBC__) && !defined(__UCLIBC_HAS_LFS__))
+ #ifndef _LARGEFILE_SOURCE
+ #define _LARGEFILE_SOURCE     1
+ #endif
+@@ -9,6 +12,7 @@
+ #ifndef _FILE_OFFSET_BITS
+ #define _FILE_OFFSET_BITS     64
+ #endif
++#endif
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
index 298c165fb7736779329771d7df85ad69e7dbb70c..2e17066f23b3519b303e6c39df0e2fc0e9acd2e9 100644 (file)
@@ -3,64 +3,14 @@
 # links (text based web browser)
 #
 #############################################################
-LINKS_VERSION:=0.99pre9-no-ssl
+LINKS_VERSION:=1.01pre1-no-ssl
 LINKS_SITE:=http://artax.karlin.mff.cuni.cz/~mikulas/vyplody/links/download/no-ssl
 LINKS_SOURCE:=links-$(LINKS_VERSION).tar.gz
-LINKS_DIR:=$(BUILD_DIR)/links-$(LINKS_VERSION)
 
-$(DL_DIR)/$(LINKS_SOURCE):
-       $(call DOWNLOAD,$(LINKS_SITE),$(LINKS_SOURCE))
+LINKS_CONF_OPT = --localstatedir=/tmp
 
-links-source: $(DL_DIR)/$(LINKS_SOURCE)
+define LINKS_INSTALL_TARGET_CMDS
+       install -c $(@D)/links $(TARGET_DIR)/usr/bin/links
+endef
 
-$(LINKS_DIR)/.unpacked: $(DL_DIR)/$(LINKS_SOURCE)
-       $(ZCAT) $(DL_DIR)/$(LINKS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(LINKS_DIR)/.unpacked
-
-$(LINKS_DIR)/.configured: $(LINKS_DIR)/.unpacked
-       (cd $(LINKS_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               $(TARGET_CONFIGURE_ARGS) \
-               ./configure $(QUIET) \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libdir=/lib \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/tmp \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               $(DISABLE_NLS) \
-       )
-       touch $(LINKS_DIR)/.configured
-
-$(LINKS_DIR)/links: $(LINKS_DIR)/.configured
-       $(MAKE) CC=$(TARGET_CC) -C $(LINKS_DIR)
-       $(STRIPCMD) $(LINKS_DIR)/links
-
-$(TARGET_DIR)/usr/bin/links: $(LINKS_DIR)/links
-       install -c $(LINKS_DIR)/links $(TARGET_DIR)/usr/bin/links
-
-links-clean:
-       -$(MAKE) -C $(LINKS_DIR) clean
-       rm -f $(TARGET_DIR)/usr/bin/links
-
-links-dirclean:
-       rm -rf $(LINKS_DIR)
-
-links: $(TARGET_DIR)/usr/bin/links
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_LINKS),y)
-TARGETS+=links
-endif
+$(eval $(call AUTOTARGETS,package,links))