package/mediastreamer: portaudio needs speexdsp
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 23 Mar 2020 18:01:20 +0000 (19:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 24 Mar 2020 20:51:58 +0000 (21:51 +0100)
Commit 8f5562ed7c227f29dbfa6897f54dccda0dfbf656 wrongly removed speexdsp
dependency from portaudio

Fixes:
 - http://autobuild.buildroot.org/results/e6adf151141ae56f5194165fd5b74b52164bfb17

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mediastreamer/mediastreamer.mk

index dcec66dfcd9a59738e6a31e414dcd8fb24fd7bb2..691eaddb528662b568b27f32f9459ed58341527b 100644 (file)
@@ -80,7 +80,8 @@ else
 MEDIASTREAMER_CONF_OPTS += -DENABLE_OPUS=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_PORTAUDIO),y)
+# portaudio backend needs speexdsp as well
+ifeq ($(BR2_PACKAGE_PORTAUDIO)$(BR2_PACKAGE_SPEEXDSP),yy)
 MEDIASTREAMER_CONF_OPTS += \
        -DENABLE_PORTAUDIO=ON \
        -DENABLE_SOUND=ON