package/dfu-util: allow to build it for the target as well
authorWolfgang Grandegger <wg@grandegger.com>
Mon, 25 Sep 2017 06:12:48 +0000 (08:12 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 26 Sep 2017 22:15:49 +0000 (00:15 +0200)
Signed-off-by: Wolfgang Grandegger <wg@grandegger.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in
package/dfu-util/Config.in [new file with mode: 0644]
package/dfu-util/dfu-util.mk

index 6acd0c440eec957b3a5e193790ee3f359421c0c9..1580a9e3d66ecc96fbf25fd1fb0a57afc182a55a 100644 (file)
@@ -391,6 +391,7 @@ endmenu
        source "package/dbus-python/Config.in"
        source "package/dbus-triggerd/Config.in"
        source "package/devmem2/Config.in"
+       source "package/dfu-util/Config.in"
        source "package/dmidecode/Config.in"
        source "package/dmraid/Config.in"
        source "package/dt-utils/Config.in"
diff --git a/package/dfu-util/Config.in b/package/dfu-util/Config.in
new file mode 100644 (file)
index 0000000..2f45fcd
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_DFU_UTIL
+       bool "dfu-util"
+       select BR2_PACKAGE_LIBUSB
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         Dfu-util is the host side implementation of the DFU 1.0
+         specification of the USB forum. DFU is intended to download
+         and upload firmware to devices connected over USB.
+
+         http://dfu-util.sourceforge.net/
+
+comment "dfu-util needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
index c494485087a9b76e71eb4864d11ab3e579cdcfe9..5e8ba5a8f2b4fefbbb5aef5bdca4c83b92e7242c 100644 (file)
@@ -9,6 +9,8 @@ DFU_UTIL_SITE = http://dfu-util.sourceforge.net/releases
 DFU_UTIL_LICENSE = GPL-2.0+
 DFU_UTIL_LICENSE_FILES = COPYING
 
+DFU_UTIL_DEPENDENCIES = libusb
 HOST_DFU_UTIL_DEPENDENCIES = host-libusb
 
+$(eval $(autotools-package))
 $(eval $(host-autotools-package))