package/libffi: disable use of static exec trampolines
authorRomain Naour <romain.naour@gmail.com>
Mon, 23 Aug 2021 11:27:29 +0000 (13:27 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 25 Aug 2021 19:45:45 +0000 (21:45 +0200)
TestGst1Python test segfault since the libffi bump to 3.4.2.

Apply the same fix from Yocto [1] disabling static exec trampolines.

Fixes:
https://gitlab.com/kubu93/buildroot/-/jobs/1522848331

[1] http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=dadfef3950fae4e93ce4c13ab91a2a7f41b3702e

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libffi/libffi.mk

index 0ef27869886d4fbd6b4b9f86b9c94a750c09b0d1..85b4ab5b846e198f25dafd690bdb169615919662 100644 (file)
@@ -13,5 +13,9 @@ LIBFFI_INSTALL_STAGING = YES
 # We're patching Makefile.am
 LIBFFI_AUTORECONF = YES
 
+# The static exec trampolines is enabled by default since
+# libffi 3.4.2. However it doesn't work with gobject-introspection.
+LIBFFI_CONF_OPTS = --disable-exec-static-tramp
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))