imagemagick: remove fixed jpeg+tiff dependencies, add optional deps
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Oct 2010 19:11:10 +0000 (21:11 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 5 Oct 2010 07:15:06 +0000 (09:15 +0200)
For fontconfig/freetype/jpeg/libpng/librsvg/libxml2/tiff.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/imagemagick/Config.in
package/imagemagick/imagemagick.mk

index d6d6d8bc5431e677848034df2630be98a041e847..e66ded00329398eb283990ce303b255b213b633f 100644 (file)
@@ -1,7 +1,5 @@
 config BR2_PACKAGE_IMAGEMAGICK
        bool "imagemagick"
-       select BR2_PACKAGE_JPEG
-       select BR2_PACKAGE_TIFF
        help
          ImageMagick(R) is a software suite to create, edit, and compose
          bitmap images. It can read, convert and write images in a variety of
index f80fe6f06821bfd7b480e67802e955bb76b36ac1..f14adb9a02c44bce1f4bf740f92ce9ad38d05d8b 100644 (file)
@@ -10,8 +10,6 @@ IMAGEMAGICK_SITE = ftp://ftp.imagemagick.org/pub/ImageMagick
 IMAGEMAGICK_LIBTOOL_PATCH = NO
 IMAGEMAGICK_INSTALL_STAGING = YES
 
-IMAGEMAGICK_DEPENDENCIES = jpeg tiff
-
 ifeq ($(BR2_LARGEFILE),y)
 IMAGEMAGICK_CONF_ENV = ac_cv_sys_file_offset_bits=64
 else
@@ -21,8 +19,6 @@ endif
 IMAGEMAGICK_CONF_OPT = --program-transform-name='s,,,' \
                --without-perl \
                --without-wmf \
-               --without-xml \
-               --without-rsvg \
                --without-openexr \
                --without-jp2 \
                --without-jbig \
@@ -31,7 +27,55 @@ IMAGEMAGICK_CONF_OPT = --program-transform-name='s,,,' \
                --without-dps \
                --without-gslib \
                --without-fpx \
-               --without-freetype \
                --without-x
 
+ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
+IMAGEMAGICK_CONF_OPT += --with-fontconfig
+IMAGEMAGICK_DEPENDENCIES += fontconfig
+else
+IMAGEMAGISK_CONF_OPT += --without-fontconfig
+endif
+
+ifeq ($(BR2_PACKAGE_FREETYPE),y)
+IMAGEMAGICK_CONF_OPT += --with-freetype
+IMAGEMAGICK_DEPENDENCIES += freetype
+else
+IMAGEMAGISK_CONF_OPT += --without-freetype
+endif
+
+ifeq ($(BR2_PACKAGE_JPEG),y)
+IMAGEMAGICK_CONF_OPT += --with-jpeg
+IMAGEMAGICK_DEPENDENCIES += jpeg
+else
+IMAGEMAGISK_CONF_OPT += --without-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+IMAGEMAGICK_CONF_OPT += --with-png
+IMAGEMAGICK_DEPENDENCIES += libpng
+else
+IMAGEMAGISK_CONF_OPT += --without-png
+endif
+
+ifeq ($(BR2_PACKAGE_LIBRSVG),y)
+IMAGEMAGICK_CONF_OPT += --with-rsvg
+IMAGEMAGICK_DEPENDENCIES += librsvg
+else
+IMAGEMAGISK_CONF_OPT += --without-rsvg
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+IMAGEMAGICK_CONF_OPT += --with-xml
+IMAGEMAGICK_DEPENDENCIES += libxml2
+else
+IMAGEMAGISK_CONF_OPT += --without-xml
+endif
+
+ifeq ($(BR2_PACKAGE_TIFF),y)
+IMAGEMAGICK_CONF_OPT += --with-tiff
+IMAGEMAGICK_DEPENDENCIES += tiff
+else
+IMAGEMAGISK_CONF_OPT += --without-tiff
+endif
+
 $(eval $(call AUTOTARGETS,package,imagemagick))