host-gdb: enable terminal user interface support
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 29 Aug 2014 19:42:31 +0000 (21:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 30 Aug 2014 07:03:34 +0000 (09:03 +0200)
Add a configuration option to compile host-gdb with the
--enable-tui switch.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/Config.in.host
package/gdb/gdb.mk

index cbc1361d8c0ce7e458a4777ce3a31bb0d4cd11d3..8846eafa154bced87c835630b0f3592ca3bfc181 100644 (file)
@@ -13,6 +13,12 @@ config BR2_PACKAGE_HOST_GDB
 
 if BR2_PACKAGE_HOST_GDB
 
+config BR2_PACKAGE_HOST_GDB_TUI
+       bool "GDB TUI support"
+       select BR2_PACKAGE_NCURSES
+       help
+         This option enables terminal user interface (TUI) for gdb
+
 choice
        prompt "GDB debugger Version"
        depends on !BR2_arc
index 8ab264ba05735a86c955b7cae9327062e693b3e1..7e87bf97a2b23105e113e75efc68cc48d5e9c594 100644 (file)
@@ -114,7 +114,6 @@ HOST_GDB_CONF_OPT = \
        --target=$(GNU_TARGET_NAME) \
        --enable-static --disable-shared \
        --without-uiout \
-       --disable-tui \
        --disable-gdbtk \
        --without-x \
        --enable-threads \
@@ -123,6 +122,13 @@ HOST_GDB_CONF_OPT = \
        $(GDB_DISABLE_BINUTILS_CONF_OPT) \
        --disable-sim
 
+ifeq ($(BR2_PACKAGE_HOST_GDB_TUI),y)
+       HOST_GDB_DEPENDENCIES += host-ncurses
+       HOST_GDB_CONF_OPT += --enable-tui
+else
+       HOST_GDB_CONF_OPT += --disable-tui
+endif
+
 ifeq ($(GDB_FROM_GIT),y)
 HOST_GDB_DEPENDENCIES += host-texinfo
 else