gst1-plugins-bad: add new timecode plugin
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 3 Nov 2016 09:58:34 +0000 (06:58 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 22:21:05 +0000 (23:21 +0100)
Add a new explicit option for the dependency-less timecode plugin.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 1e251afec6e4ee9f9694746654d33877f3bebc7c..40bb2834e4eb4e25bd6278aa15c1cc537a6c993e 100644 (file)
@@ -419,6 +419,9 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SUBENC
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_STEREO
        bool "stereo"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TIMECODE
+       bool "timecode"
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA
        bool "tta"
 
index ba9f8ffd0863c3af5ee28224e1b77e10e2f05ab4..012b948b2cfdcb0d27dd5edc51d6560b8f0d96db 100644 (file)
@@ -517,6 +517,12 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-stereo
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TIMECODE),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-timecode
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-timecode
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_TTA),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-tta
 else