mesa3d: Pass LDFLAGS to the build config file
authorClark Rawlins <clark@bit63.org>
Tue, 1 Dec 2009 13:46:27 +0000 (08:46 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 Dec 2009 19:13:28 +0000 (20:13 +0100)
Closes #559.

Without the LDFLAGS in the build configuration file
building mesa3d fails with an external toolchain on amd64
machines targeting i686.  The error indicats that libX11
can't be found.

This change passes the --sysroot parameter (along with any
others specified by buildroot for LDFLAGS to the mklib script.

Signed-off-by: Clark Rawlins <clark@bit63.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/x11r7/mesa3d/mesa3d.mk

diff --git a/CHANGES b/CHANGES
index a40fd396ee9ff502e48add330f3bfd89877ae562..b99f11d65492244848a18b88bcf0a5a22114e826 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1,10 +1,11 @@
 2010.02, Not yet released:
 
        Updated/fixed packages: autoconf, bind, binutils, busybox, iw,
-       lighttpd, pcre, usbutils
+       lighttpd, mesa, pcre, usbutils
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #559: mesa3d build fails
        #749: Bump usbutils package to version 0.86
        #751: Kernel 2.6 snapshot fetch fail
        #753: Bump lighttpd package to 1.4.25
index 945765f9c798fab4b1956353069d7626e168db04..fa98bf6056250825e832bb050733ed3c6cc10c36 100644 (file)
@@ -49,6 +49,7 @@ $(MESA3D_DIR)/.configured: $(MESA3D_DIR)/.extracted
                echo "X11_INCLUDES = " && \
                echo "EXTRA_LIB_PATH = " && \
                echo "PROGRAM_DIRS =" && \
+               echo "LDFLAGS = $(TARGET_LDFLAGS)" && \
                echo "MKDEP_OPTIONS = -fdepend -Y$(STAGING_DIR)/usr/include -I$(MESA_GCCINCLUDE)" \
        ) >> $(MESA_CONFIG_FILE)
        touch $@