package/php: fix building curl extension
authorAdam Duskett <Aduskett@gmail.com>
Thu, 27 Dec 2018 17:49:02 +0000 (12:49 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 28 Dec 2018 12:53:07 +0000 (13:53 +0100)
The configure option "--with-curl=$(STAGING_DIR)/usr" is broken.
PHP will detect libcurl.pc, which will pass the configure checks, but will then
prepend $(STAGING_DIR)/usr to the paths in libcurl.pc.

Thus php will then search $(STAGING_DIR)/usr/$(STAGING_DIR)/usr/lib/ for
curl libraries during linking, which causes linking errors.

Removing "=$(STAGING_DIR)/usr" from --with-curl fixes the issue.

Fixes:

  http://autobuild.buildroot.net/results/44b9ea1edca85b222a117a8e241a26b8dce33929/

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/php/php.mk

index b95ceb5c9d05b25866aca88457f87ed174de3c53..338361f58a07be02240bd4807ec85e790b5befb8 100644 (file)
@@ -259,7 +259,7 @@ endif
 endif
 
 ifeq ($(BR2_PACKAGE_PHP_EXT_CURL),y)
-PHP_CONF_OPTS += --with-curl=$(STAGING_DIR)/usr
+PHP_CONF_OPTS += --with-curl
 PHP_DEPENDENCIES += libcurl
 endif