package/optee-examples: use the OPTEE_OS_SDK variable
authorEtienne Carriere <etienne.carriere@linaro.org>
Fri, 1 Mar 2019 16:47:07 +0000 (17:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 5 Mar 2019 20:54:32 +0000 (21:54 +0100)
The optee-os package was recently changed to provide the OPTEE_OS_SDK
to allow other packages to locate the OP-TEE Trusted Application SDK,
so let's use this new variable in the optee-examples package.

Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
[Thomas: use the new variable name, rework commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/optee-examples/optee-examples.mk

index 10fe62b72a102a3e9fa1e71ee4ae052a28c88f7c..f2163b8643ae9c17711c5916a6442170c9e23c69 100644 (file)
@@ -11,19 +11,13 @@ OPTEE_EXAMPLES_LICENSE_FILES = LICENSE
 
 OPTEE_EXAMPLES_DEPENDENCIES = optee-client optee-os
 
-ifeq ($(BR2_aarch64),y)
-OPTEE_EXAMPLES_SDK = $(STAGING_DIR)/lib/optee/export-ta_arm64
-else ifeq ($(BR2_arm),y)
-OPTEE_EXAMPLES_SDK = $(STAGING_DIR)/lib/optee/export-ta_arm32
-endif
-
 # Trusted Application are not built from CMake due to ta_dev_kit dependencies.
 # We must build and install them on target.
 define OPTEE_EXAMPLES_BUILD_TAS
        $(foreach f,$(wildcard $(@D)/*/ta/Makefile), \
                $(TARGET_CONFIGURE_OPTS) \
                $(MAKE) CROSS_COMPILE=$(TARGET_CROSS) \
-                       TA_DEV_KIT_DIR=$(OPTEE_EXAMPLES_SDK) \
+                       TA_DEV_KIT_DIR=$(OPTEE_OS_SDK) \
                        O=out -C $(dir $f) all
        )
 endef