imlib2: handle imlib2-config script
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 10 May 2013 06:29:26 +0000 (06:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 May 2013 20:39:41 +0000 (22:39 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/imlib2/imlib2.mk

index c7029aeb6fd2e0dd4c33ffe1a0c267c796cfa205..cec67066bece08faf700c0c6be00b4e8b44c3d47 100644 (file)
@@ -12,6 +12,7 @@ IMLIB2_LICENSE_FILES = COPYING
 IMLIB2_INSTALL_STAGING = YES
 IMLIB2_DEPENDENCIES = host-pkgconf freetype
 IMLIB2_CONF_OPT = --with-freetype-config=$(STAGING_DIR)/usr/bin/freetype-config
+IMLIB2_CONFIG_SCRIPTS = imlib2-config
 
 ifeq ($(BR2_PACKAGE_IMLIB2_X),y)
        IMLIB2_CONF_OPT += --with-x
@@ -57,10 +58,7 @@ endif
 
 # drop -L<dir> from linker flags
 define IMLIB2_FIXUP_IMLIB2_CONFIG
-       $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \
-               -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
-               -e  's/-L[^ ]*//g' \
-               $(STAGING_DIR)/usr/bin/imlib2-config
+       $(SED) 's/-L[^ ]*//g' $(STAGING_DIR)/usr/bin/imlib2-config
 endef
 
 IMLIB2_POST_INSTALL_STAGING_HOOKS += IMLIB2_FIXUP_IMLIB2_CONFIG