Makefile: implement a graph-size target
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Oct 2015 13:33:44 +0000 (15:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Oct 2015 14:13:05 +0000 (16:13 +0200)
This commit implements a graph-size target that calls the script of
the same name to generate the graph and CSV files related to package
and file sizes.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 181d44685f2c04559601a3d58622f1d2dd1093be..c871393b79d93e0181e629ecdcfc83f6c75c7fd4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -686,6 +686,13 @@ graph-depends: graph-depends-requirements
        |tee $(GRAPHS_DIR)/$(@).dot \
        |dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(GRAPHS_DIR)/$(@).$(BR_GRAPH_OUT)
 
+graph-size:
+       $(Q)mkdir -p $(GRAPHS_DIR)
+       $(Q)$(TOPDIR)/support/scripts/size-stats --builddir $(BASE_DIR) \
+               --graph $(GRAPHS_DIR)/graph-size.$(BR_GRAPH_OUT) \
+               --file-size-csv $(GRAPHS_DIR)/file-size-stats.csv \
+               --package-size-csv $(GRAPHS_DIR)/package-size-stats.csv
+
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 all: menuconfig
@@ -903,6 +910,7 @@ endif
        @echo '  manual-epub            - build manual in ePub'
        @echo '  graph-build            - generate graphs of the build times'
        @echo '  graph-depends          - generate graph of the dependency tree'
+       @echo '  graph-size             - generate stats of the filesystem size'
        @echo '  list-defconfigs        - list all defconfigs (pre-configured minimal systems)'
        @echo
        @echo 'Miscellaneous:'