dbus: fix build on microblaze
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Dec 2012 00:23:34 +0000 (01:23 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Dec 2012 00:23:34 +0000 (01:23 +0100)
Fixes http://autobuild.buildroot.net/results/5963d35b8933c452b8574c964e407c23a5d0412f

The microblaze toolchain has sys/inotify.h, but doesn't provide inotify_rm_*
functions, so disable inotify support.

Also disable the legacy dnotify support (which is used when inotify support
is disabled) as it has bitrotten upstream and no longer builds.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dbus/dbus.mk

index b7cc37820a52f1439d3a269527ebfe97defd1797..ec42874b62c41a8b8be280a6470e896385808b7c 100644 (file)
@@ -18,11 +18,16 @@ DBUS_CONF_OPT = --with-dbus-user=dbus \
                --disable-xml-docs \
                --disable-doxygen-docs \
                --disable-static \
-               --enable-dnotify \
+               --disable-dnotify \
                --localstatedir=/var \
                --with-system-socket=/var/run/dbus/system_bus_socket \
                --with-system-pid-file=/var/run/messagebus.pid
 
+ifeq ($(BR2_microblaze),y)
+# microblaze toolchain doesn't provide inotify_rm_* but does have sys/inotify.h
+DBUS_CONF_OPT += --disable-inotify
+endif
+
 ifeq ($(BR2_DBUS_EXPAT),y)
 DBUS_CONF_OPT += --with-xml=expat
 DBUS_DEPENDENCIES += expat