package/gstreamer1/gst1-plugins-bad: add fluidsynth option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 10 Jan 2020 22:02:39 +0000 (23:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Jan 2020 14:48:43 +0000 (15:48 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 393950ef2f6a723fdc9a0cf1394956b22fbb1cab..d831f8072e8de75d0dc2b1322fc4cffd121acf60 100644 (file)
@@ -397,6 +397,19 @@ comment "fdk-aac needs a toolchain w/ C++"
        depends on BR2_PACKAGE_FDK_AAC_ARCH_SUPPORTS
        depends on !BR2_INSTALL_LIBSTDCPP
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_FLUIDSYNTH
+       bool "fluidsynth"
+       depends on BR2_USE_WCHAR # fluidsynth
+       depends on BR2_TOOLCHAIN_HAS_THREADS # fluidsynth
+       depends on BR2_USE_MMU # fluidsynth
+       select BR2_PACKAGE_FLUIDSYNTH
+       help
+         Fluidsynth MIDI decoder plugin
+
+comment "fluidsynth needs a toolchain w/ threads, wchar"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL
        bool "gl"
        default y
index 259f00cdbbd13c6e04ddb5afdb3b8d0419774827..ef36e4dc0aa8645f1b416827b898c7304b952e5b 100644 (file)
@@ -42,7 +42,6 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        -Dfaac=disabled \
        -Dflite=disabled \
        -Dgsm=disabled \
-       -Dfluidsynth=disabled \
        -Dkate=disabled \
        -Dladspa=disabled \
        -Dlv2=disabled \
@@ -526,6 +525,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += -Dfdkaac=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_FLUIDSYNTH),y)
+GST1_PLUGINS_BAD_CONF_OPTS += -Dfluidsynth=enabled
+GST1_PLUGINS_BAD_DEPENDENCIES += fluidsynth
+else
+GST1_PLUGINS_BAD_CONF_OPTS += -Dfluidsynth=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL),y)
 GST1_PLUGINS_BAD_CONF_OPTS += -Dgl=enabled
 else