usbutils: build after busybox if enabled
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 15 Oct 2011 03:07:25 +0000 (00:07 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Oct 2011 21:06:51 +0000 (23:06 +0200)
Build after busybox if it's enabled since full-blown lsusb is better
than busybox lsusb.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/usbutils/usbutils.mk

index 7da8eda9722240752fd7aa5ca38e0dc53f056cf9..e89f02e099db81093d9a40cdc49f66470d92e459 100644 (file)
@@ -15,6 +15,11 @@ else
        USBUTILS_CONF_OPT = --disable-zlib
 endif
 
+# Build after busybox since it's got a lightweight lsusb
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+       USBUTILS_DEPENDENCIES += busybox
+endif
+
 define USBUTILS_TARGET_CLEANUP
        rm -f $(TARGET_DIR)/usr/bin/usb-devices
        rm -f $(TARGET_DIR)/usr/sbin/update-usbids.sh