samrobb writes in Bug 233: only clean host sed if we built it
authorMike Frysinger <vapier@gentoo.org>
Thu, 8 Sep 2005 00:39:33 +0000 (00:39 -0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 8 Sep 2005 00:39:33 +0000 (00:39 -0000)
package/sed/sed.mk

index 6e31973968e54f0ccc760cf9c1b03024d70f19fa..024ecbba117db9b8a1a4e182b6da9e6a071df75f 100644 (file)
@@ -70,6 +70,7 @@ use-sed-host-binary:
 
 host-sed: $(HOST_SED_TARGET)
 
+ifeq ($(HOST_SED_TARGET),build-sed-host-binary)
 host-sed-clean:
        $(MAKE) DESTDIR=$(HOST_SED_DIR) -C $(SED_DIR1) uninstall
        -$(MAKE) -C $(SED_DIR1) clean
@@ -77,6 +78,10 @@ host-sed-clean:
 host-sed-dirclean:
        rm -rf $(SED_DIR1)
 
+else
+host-sed-clean host-sed-dirclean:
+
+endif
 
 #############################################################
 #