curlftpfs: use new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:41:06 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:24 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/curlftpfs/Config.in
package/curlftpfs/curlftpfs.mk

index 986faf157c582c711ea9c6e763fca6030c39f65f..c8c432f20589b175c3a8e3cc70a2fcfe8863f149 100644 (file)
@@ -6,7 +6,6 @@ config BR2_PACKAGE_CURLFTPFS
        depends on !BR2_STATIC_LIBS # libfuse
        select BR2_PACKAGE_LIBFUSE
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_LIBCURL
index 585dbf26d36809d33ee52b3e10b1771588df696c..584d01a6d427a4daa6a61d2262f7c284cb6eb63f 100644 (file)
@@ -11,7 +11,7 @@ CURLFTPFS_LICENSE = GPL-2.0
 CURLFTPFS_LICENSE_FILES = COPYING
 CURLFTPFS_DEPENDENCIES = \
        libglib2 libfuse openssl libcurl \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+       $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_ENABLE_LOCALE),,libiconv)
 
 $(eval $(autotools-package))