netsnmp: cleanup configure flags handling
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 16 May 2014 20:28:38 +0000 (22:28 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 16 May 2014 20:31:21 +0000 (22:31 +0200)
No functional change, but cleaner.

Remove the double --disable-manuals and move the debug handling together
with the other optional configure flags.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/netsnmp/netsnmp.mk

index 75956d4e61896ab89a492db79d7fb328dc9a0630..1372f2fcd3d202a9c7366bc908b09ce5f1f23428 100644 (file)
@@ -50,14 +50,15 @@ else
        NETSNMP_CONF_OPT += --without-openssl
 endif
 
-# Docs
-NETSNMP_CONF_OPT += --disable-manuals
-
 ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_MIBS),y)
        NETSNMP_CONF_OPT += --disable-mib-loading
        NETSNMP_CONF_OPT += --disable-mibs
 endif
 
+ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING),y)
+       NETSNMP_CONF_OPT += --disable-debugging
+endif
+
 # Remove IPv6 MIBs if there's no IPv6
 ifneq ($(BR2_INET_IPV6),y)
 define NETSNMP_REMOVE_MIBS_IPV6
@@ -67,11 +68,6 @@ endef
 NETSNMP_POST_INSTALL_TARGET_HOOKS += NETSNMP_REMOVE_MIBS_IPV6
 endif
 
-ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING),y)
-       NETSNMP_CONF_OPT += --disable-debugging
-endif
-
-
 define NETSNMP_REMOVE_BLOAT_MIBS
        for mib in $(NETSNMP_BLOAT_MIBS); do \
                rm -f $(TARGET_DIR)/usr/share/snmp/mibs/$$mib-MIB.txt; \