package/libpfm4: disable Werror
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 13 Aug 2015 20:16:38 +0000 (22:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Aug 2015 08:59:58 +0000 (10:59 +0200)
Set `DBG` to an empty value to disable -Werror when building libpfm4. Build
aborts with a musl toolchain because of warnings about redirecting incorrect
header includes.

So -Werror shouldn't be used in released code since it can cause random build
failures on moderate warnings. It also depends on the used toolchain since
different toolchains may or may not print the same warnings.

Fixes:
http://autobuild.buildroot.net/results/6df/6df9b94a79be1dc5ba878f7b67bf9ad4ce2f2e98/

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpfm4/libpfm4.mk

index e2fff80882e8ea3620d836c672f48636141f1930..7f147584449e8ed7e2f6f117769102f5a143f1ee 100644 (file)
@@ -13,7 +13,8 @@ LIBPFM4_INSTALL_STAGING = YES
 
 LIBPFM4_FLAGS = SYS=Linux ARCH=$(BR2_ARCH) \
        CC="$(TARGET_CC)" LDCONFIG=true \
-       CONFIG_PFMLIB_SHARED=$(if $(BR2_STATIC_LIBS),n,y)
+       CONFIG_PFMLIB_SHARED=$(if $(BR2_STATIC_LIBS),n,y) \
+       DBG=
 
 define LIBPFM4_BUILD_CMDS
        $(MAKE) -C $(@D) $(LIBPFM4_FLAGS)