lxc: enable selinux if package is selected
authorFabrice Fontaine <fabrice.fontaine@orange.com>
Fri, 10 Feb 2017 16:17:10 +0000 (17:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Feb 2017 15:45:38 +0000 (16:45 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lxc/lxc.mk

index 455814b9c98ed3ce964a4d5bf8a03237a8ec916b..b79197fa577790b25681c3f0715961f25d2909d0 100644 (file)
@@ -29,6 +29,13 @@ else
 LXC_CONF_OPTS += --disable-seccomp
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+LXC_CONF_OPTS += --enable-selinux
+LXC_DEPENDENCIES += libselinux
+else
+LXC_CONF_OPTS += --disable-selinux
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER),y)
 LXC_CONF_OPTS += --enable-lua
 LXC_DEPENDENCIES += luainterpreter