xfsprogs: Define PLATFORM to linux
authorFlorian Fainelli <f.fainelli@gmail.com>
Thu, 29 Nov 2018 05:05:40 +0000 (21:05 -0800)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 29 Nov 2018 15:29:24 +0000 (16:29 +0100)
PLATFORM is an environment variable used by xfsprogs' configure script
to determine the platform for which the applications are being built. If
we set some incorrect/unsupported value through e.g: export, this will
be picked up by xfsprogs' configure script and used as-is and assigned
to PKG_PLATFORM, which will lead to build failures.

If PLATFORM was empty/unset, then uname on the host building xfsprogs
gets used to determine the build platform, which again could be
incorrect if we e.g: built xfsprogs on a Darwin system.

Since we are obviously building for Linux, let's just make sure we
define it that way which solves both issues.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xfsprogs/xfsprogs.mk

index b5975d29e1a17e767e4d3ed528371273cdfd68c5..bbb888707b20000a481e8d00d207bd4a978e67ba 100644 (file)
@@ -12,7 +12,7 @@ XFSPROGS_LICENSE_FILES = LICENSES/GPL-2.0 LICENSES/LGPL-2.1
 
 XFSPROGS_DEPENDENCIES = util-linux
 
-XFSPROGS_CONF_ENV = ac_cv_header_aio_h=yes ac_cv_lib_rt_lio_listio=yes
+XFSPROGS_CONF_ENV = ac_cv_header_aio_h=yes ac_cv_lib_rt_lio_listio=yes PLATFORM="linux"
 XFSPROGS_CONF_OPTS = \
        --enable-lib64=no \
        --enable-gettext=no \