package/go: security bump to version 1.13.3
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Oct 2019 21:27:28 +0000 (22:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 28 Oct 2019 07:43:17 +0000 (08:43 +0100)
Fixes the following security issues (1.33.2):

- CVE-2019-17596: Invalid DSA public keys can cause a panic in dsa.Verify.
  In particular, using crypto/x509.Verify on a crafted X.509 certificate
  chain can lead to a panic, even if the certificates don’t chain to a
  trusted root.  The chain can be delivered via a crypto/tls connection to a
  client, or to a server that accepts and verifies client certificates.
  net/http clients can be made to crash by an HTTPS server, while net/http
  servers that accept client certificates will recover the panic and are
  unaffected.

Additionally, 1.13.3 fixes a number of issues. From the release notes:

Fixes to the go command, the toolchain, the runtime, syscall, net, net/http,
and crypto/ecdsa packages

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/go/go.hash
package/go/go.mk

index 3c6799c5fcf3a10f01833087db829e6a25d34da9..442a6f9ad2015eec5319637cb76bbb0730877037 100644 (file)
@@ -1,3 +1,3 @@
 # From https://golang.org/dl/
-sha256 81f154e69544b9fa92b1475ff5f11e64270260d46e7e36c34aafc8bc96209358  go1.13.1.src.tar.gz
+sha256 4f7123044375d5c404280737fbd2d0b17064b66182a65919ffe20ffe8620e3df  go1.13.3.src.tar.gz
 sha256 2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
index 73c049412c373089d4cc1a525226b662ef8f273c..64e831189f2cbbd63324ccded4abb7441ad98314 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GO_VERSION = 1.13.1
+GO_VERSION = 1.13.3
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz