dbus-glib: convert to autotools infrastructure for host package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 6 Nov 2009 18:14:36 +0000 (19:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Dec 2009 18:57:37 +0000 (19:57 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dbus-glib/dbus-glib.mk

index c6cebe63d291a47e5f12643282ec6859035e2b7f..0bf2b3f41b2732c6e3fcbe2c928507206acdc20d 100644 (file)
@@ -25,53 +25,17 @@ DBUS_GLIB_CONF_OPT = --localstatedir=/var \
 
 DBUS_GLIB_DEPENDENCIES = host-pkg-config dbus host-dbus host-dbus-glib libglib2 expat
 
-$(eval $(call AUTOTARGETS,package,dbus-glib))
-
-# dbus-glib for the host
-DBUS_GLIB_HOST_DIR:=$(BUILD_DIR)/dbus-glib-$(DBUS_GLIB_VERSION)-host
-DBUS_GLIB_HOST_BINARY:=$(HOST_DIR)/usr/bin/dbus-binding-tool
+HOST_DBUS_GLIB_DEPENDENCIES = host-dbus host-exapt host-libglib2
 
-$(DL_DIR)/$(DBUS_GLIB_SOURCE):
-       $(call DOWNLOAD,$(DBUS_GLIB_SITE),$(DBUS_GLIB_SOURCE))
-
-$(STAMP_DIR)/host_dbusglib_unpacked: $(DL_DIR)/$(DBUS_GLIB_SOURCE)
-       mkdir -p $(DBUS_GLIB_HOST_DIR)
-       $(INFLATE$(suffix $(DBUS_GLIB_SOURCE))) $< | \
-               $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(DBUS_GLIB_HOST_DIR) $(TAR_OPTIONS) -
-       touch $@
-
-$(STAMP_DIR)/host_dbusglib_configured: $(STAMP_DIR)/host_dbusglib_unpacked $(STAMP_DIR)/host_dbus_installed $(STAMP_DIR)/host_expat_installed $(STAMP_DIR)/host_libglib2_installed
-       (cd $(DBUS_GLIB_HOST_DIR); rm -rf config.cache; \
-               $(HOST_CONFIGURE_OPTS) \
-               CFLAGS="$(HOST_CFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS)" \
-               ./configure $(QUIET) \
-               --prefix="$(HOST_DIR)/usr" \
-               --sysconfdir="$(HOST_DIR)/etc" \
+HOST_DBUS_GLIB_CONF_OPT = \
                --disable-tests \
                --disable-xml-docs \
                --disable-bash-completion \
                --disable-doxygen-docs \
-               --enable-asserts=yes \
-       )
-       touch $@
-
-$(STAMP_DIR)/host_dbusglib_compiled: $(STAMP_DIR)/host_dbusglib_configured
-       $(HOST_MAKE_ENV) $(MAKE) -C $(DBUS_GLIB_HOST_DIR)
-       touch $@
-
-$(STAMP_DIR)/host_dbusglib_installed: $(STAMP_DIR)/host_dbusglib_compiled
-       $(HOST_MAKE_ENV) $(MAKE) -C $(DBUS_GLIB_HOST_DIR) install
-       touch $@
-
-host-dbus-glib: $(STAMP_DIR)/host_dbusglib_installed
-
-host-dbus-glib-source: dbus-glib-source
+               --enable-asserts=yes
 
-host-dbus-glib-clean:
-       rm -f $(addprefix $(STAMP_DIR)/host_dbusglib_,unpacked configured compiled installed)
-       -$(MAKE) -C $(DBUS_GLIB_HOST_DIR) uninstall
-       -$(MAKE) -C $(DBUS_GLIB_HOST_DIR) clean
+$(eval $(call AUTOTARGETS,package,dbus-glib))
+$(eval $(call AUTOTARGETS,package,dbus-glib,host))
 
-host-dbus-glib-dirclean:
-       rm -rf $(DBUS_GLIB_HOST_DIR)
+# dbus-glib for the host
+DBUS_GLIB_HOST_BINARY:=$(HOST_DIR)/usr/bin/dbus-binding-tool