qt5script: install examples to target
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Tue, 12 Jun 2018 12:32:01 +0000 (08:32 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 12:35:09 +0000 (14:35 +0200)
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `script' from the staging directory to
the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5script/qt5script.mk

index fe0ad9e888ee31ee43a19cbdc5dd39a3cf8bcf03..4a292c95a536d7137aa3c4b86a8ea0cbc4a605aa 100644 (file)
@@ -41,9 +41,20 @@ define QT5SCRIPT_INSTALL_STAGING_CMDS
 endef
 
 ifeq ($(BR2_STATIC_LIBS),)
-define QT5SCRIPT_INSTALL_TARGET_CMDS
+define QT5SCRIPT_INSTALL_TARGET_LIBS
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Script*.so.* $(TARGET_DIR)/usr/lib
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5SCRIPT_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/script $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
+define QT5SCRIPT_INSTALL_TARGET_CMDS
+       $(QT5SCRIPT_INSTALL_TARGET_LIBS)
+       $(QT5SCRIPT_INSTALL_TARGET_EXAMPLES)
+endef
+
 $(eval $(generic-package))