lua: ensure pkgconfig directory exists before installing files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Aug 2017 20:23:03 +0000 (22:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Aug 2017 20:24:07 +0000 (22:24 +0200)
The lua staging and host installation commands generate a file in
usr/lib/pkgconfig, without first making sure that this directory
exists, which causes build failures if it doesn't. This commit adjusts
those installation commands to create this directory if needed.

Fixes:

  http://autobuild.buildroot.net/results/101c89e1d6aee942a0b1c4e4f3daf8ac2414a56c/

Based on investigation and initial (more complicated) fix provided by
Francois Perrad <francois.perrad@gadz.org>.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lua/lua.mk

index 0692c537642a14f083ca10988e1139df8f840e6b..ee39480dc535f7c67fd95a28fe6e3c4bb9bf080e 100644 (file)
@@ -86,6 +86,7 @@ endef
 
 define LUA_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) INSTALL_TOP="$(STAGING_DIR)/usr" -C $(@D) install
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig/
        sed -e "s/@MYLIBS@/$(LUA_MYLIBS)/g" $(@D)/etc/lua.pc \
                > $(STAGING_DIR)/usr/lib/pkgconfig/lua.pc
 endef
@@ -96,6 +97,7 @@ endef
 
 define HOST_LUA_INSTALL_CMDS
        $(HOST_MAKE_ENV) $(MAKE) INSTALL_TOP="$(HOST_DIR)" -C $(@D) install
+       mkdir -p $(HOST_DIR)/lib/pkgconfig/
        sed -e "s/@MYLIBS@/$(HOST_LUA_MYLIBS)/g" $(@D)/etc/lua.pc \
                > $(HOST_DIR)/lib/pkgconfig/lua.pc
 endef