boot/opensbi: bump to 0.5
authorAlistair Francis <alistair.francis@wdc.com>
Wed, 16 Oct 2019 22:55:25 +0000 (15:55 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 17 Oct 2019 07:49:56 +0000 (09:49 +0200)
Bump OpenSBI to the latest version. We need a patch for RV32 to avoid
hard/soft float build failures.

Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/opensbi/0001-Makefile-Don-t-specify-mabi-or-march.patch [new file with mode: 0644]
boot/opensbi/opensbi.hash
boot/opensbi/opensbi.mk

diff --git a/boot/opensbi/0001-Makefile-Don-t-specify-mabi-or-march.patch b/boot/opensbi/0001-Makefile-Don-t-specify-mabi-or-march.patch
new file mode 100644 (file)
index 0000000..5f554a6
--- /dev/null
@@ -0,0 +1,37 @@
+From f5871e1f3650d6c8a032928cb5d8ca00c275c377 Mon Sep 17 00:00:00 2001
+From: Alistair Francis <alistair.francis@wdc.com>
+Date: Fri, 15 Feb 2019 14:57:41 -0800
+Subject: [PATCH] Makefile: Don't specify mabi or march
+
+To avoid
+    can't link double-float modules with soft-float modules
+errors when building 32-bit openSBI don't specify mabi or march.
+
+Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
+---
+ Makefile | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ae68f55..10851fc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -145,7 +145,6 @@ GENFLAGS   +=      $(firmware-genflags-y)
+ CFLAGS                =       -g -Wall -Werror -nostdlib -fno-strict-aliasing -O2
+ CFLAGS                +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
+ CFLAGS                +=      -mno-save-restore -mstrict-align
+-CFLAGS                +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
+ CFLAGS                +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
+ CFLAGS                +=      $(GENFLAGS)
+ CFLAGS                +=      $(platform-cflags-y)
+@@ -158,7 +157,6 @@ CPPFLAGS   +=      $(firmware-cppflags-y)
+ ASFLAGS               =       -g -Wall -nostdlib -D__ASSEMBLY__
+ ASFLAGS               +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
+ ASFLAGS               +=      -mno-save-restore -mstrict-align
+-ASFLAGS               +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
+ ASFLAGS               +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
+ ASFLAGS               +=      $(GENFLAGS)
+ ASFLAGS               +=      $(platform-asflags-y)
+-- 
+2.20.1
+
index 21f802bcbc09f1952387c1dc6db43dd774475982..47d5930acebb8b257532c01ae56e0b462df5c832 100644 (file)
@@ -1,2 +1,3 @@
 # locally computed
-sha256 d3060bf51af00204ce90fc73106955c694463b59a5b81be64cf780cd32743abf opensbi-0.4.tar.gz
+sha256 bc82f1e63663cafb7976b324d8a01263510cfd816063dc89e0ccffb9763fb1dd opensbi-0.5.tar.gz
+sha256 82d13fb1bf6bb162629deeea9eb9c117e74548d3b707e478967691fe79a68e21 COPYING.BSD
index e202bd0b97b503886b63e6f72b15aef269c8678e..2df746ab009a7575a80624a3fee4ec8725814828 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-OPENSBI_VERSION = 0.4
+OPENSBI_VERSION = 0.5
 OPENSBI_SITE = $(call github,riscv,opensbi,v$(OPENSBI_VERSION))
 OPENSBI_LICENSE = BSD-2-Clause
 OPENSBI_LICENSE_FILES = COPYING.BSD