package/kodi: New option to enable support for optical drives
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 23 Dec 2014 17:46:36 +0000 (18:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 18:58:29 +0000 (19:58 +0100)
This also enables dvdcss support, provided by an internal library.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index 4bc017873a8235863f0d2afea10b0e77f2b2b380..22060b1866e5018c7c4d657ec4ca3a02e85f5395 100644 (file)
@@ -235,6 +235,11 @@ config BR2_PACKAGE_KODI_WAVPACK
          Enable WAV input support.
          Select this if you want to play back WV files.
 
+config BR2_PACKAGE_KODI_OPTICALDRIVE
+       bool "optical drive"
+       help
+         Enable support for optical drives
+
 comment "Kodi addons"
 
 source "package/kodi-addon-xvdr/Config.in"
index 14fa2445c83bab4abab1327d952f2364fabffb9a..cd1f2fb54c5aa586fa9cedddbdca2c66cfe4e927 100644 (file)
@@ -37,7 +37,6 @@ KODI_CONF_OPTS +=  \
        --disable-joystick \
        --disable-mysql \
        --disable-openmax \
-       --disable-optical-drive \
        --disable-projectm \
        --disable-pulse \
        --disable-ssh \
@@ -189,6 +188,12 @@ else
 KODI_CONF_OPTS += --disable-vaapi
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_OPTICALDRIVE),y)
+KODI_CONF_OPTS += --enable-optical-drive --enable-dvdcss
+else
+KODI_CONF_OPTS += --disable-optical-drive --disable-dvdcss
+endif
+
 # Add HOST_DIR to PATH for codegenerator.mk to find swig
 define KODI_BOOTSTRAP
        cd $(@D) && PATH=$(BR_PATH) ./bootstrap