berkeleydb: cleanup
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 25 Apr 2012 13:37:25 +0000 (15:37 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 25 Apr 2012 13:49:04 +0000 (15:49 +0200)
Use the preferred 'VAR = value' form, and remove redundant configure
options.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/berkeleydb/berkeleydb.mk

index 3d578529ad7725f5e8a04a62a32c31a0892373ed..396ba1691328f23c43374fea25f725304cd0678f 100644 (file)
@@ -3,13 +3,13 @@
 # berkeley db
 #
 #############################################################
-BERKELEYDB_VERSION:=5.3.15
-BERKELEYDB_SITE:=http://download.oracle.com/berkeley-db
-BERKELEYDB_SOURCE:=db-$(BERKELEYDB_VERSION).NC.tar.gz
-BERKELEYDB_SUBDIR=build_unix
+BERKELEYDB_VERSION = 5.3.15
+BERKELEYDB_SITE = http://download.oracle.com/berkeley-db
+BERKELEYDB_SOURCE = db-$(BERKELEYDB_VERSION).NC.tar.gz
+BERKELEYDB_SUBDIR = build_unix
 BERKELEYDB_INSTALL_STAGING = YES
 
-#build directory can't be the directory where configure are there, so..
+# build directory can't be the directory where configure are there, so..
 define BERKELEYDB_CONFIGURE_CMDS
        (cd $(@D)/build_unix; rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
@@ -20,16 +20,7 @@ define BERKELEYDB_CONFIGURE_CMDS
                --build=$(GNU_HOST_NAME) \
                --prefix=/usr \
                --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libdir=/usr/lib \
-               --libexecdir=/usr/lib \
                --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --includedir=/usr/include \
-               --mandir=/usr/share/man \
-               --infodir=/usr/share/info \
                --with-gnu-ld \
                --disable-cxx \
                --disable-java \