package/ipmiutil: really force md2 off
authorRomain Naour <romain.naour@openwide.fr>
Fri, 15 May 2015 23:06:28 +0000 (01:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 16 May 2015 13:14:48 +0000 (15:14 +0200)
If ALLOW_GNU is not defined, SKIP_MD2 is a nop.

Fixes:
http://autobuild.buildroot.net/results/f606ec1fff4cea257a4c6274bc5603efdfc439ad/

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ipmiutil/ipmiutil.mk

index c3d791cc388beedf06046baba8e364de310aa724..c7a8dd83be7d5ee00065f0eabf27a9c23919b4d9 100644 (file)
@@ -12,7 +12,8 @@ IPMIUTIL_LICENSE_FILES = COPYING
 IPMIUTIL_AUTORECONF = YES
 # tests against distro libcrypto so it might get a false positive when
 # the openssl version is old, so force it off
-IPMIUTIL_CONF_OPTS = CPPFLAGS="$(TARGET_CPPFLAGS) -DSKIP_MD2"
+# SKIP_MD2 can be used only if ALLOW_GNU is defined.
+IPMIUTIL_CONF_OPTS = CPPFLAGS="$(TARGET_CPPFLAGS) -DALLOW_GNU -DSKIP_MD2"
 IPMIUTIL_DEPENDENCIES = openssl
 
 $(eval $(autotools-package))