package/libevas-generic-loaders: add libraw dependency
authorRomain Naour <romain.naour@openwide.fr>
Tue, 15 Dec 2015 22:40:23 +0000 (23:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 22:58:32 +0000 (23:58 +0100)
libraw it's one of the "highly recommended" dependecies
according to the README [1].

[1] https://git.enlightenment.org/core/evas_generic_loaders.git/tree/README?id=v1.15.0#n31

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libevas-generic-loaders/Config.in
package/libevas-generic-loaders/libevas-generic-loaders.mk

index 65ced8a15ec3152b0b378b00dc4bd34968513e7d..1d5b71797797ed0552f5884f39451742de67a1fa 100644 (file)
@@ -11,6 +11,16 @@ config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
 
 if BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
 
+config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_LIBRAW
+       bool "libraw loader"
+       depends on BR2_INSTALL_LIBSTDCPP # libraw
+       select BR2_PACKAGE_LIBRAW
+       help
+         This option enables the Evas generic Libraw loader
+
+comment "libraw loader needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
+
 config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG
        bool "SVG loader"
        depends on BR2_USE_MMU # librsvg -> glib2
index 47dfa9a07922331c5b23bfc9d597bb5a975b7c0d..2c1c1cddf21a501299bbe65227ad7a7c28382bff 100644 (file)
@@ -14,15 +14,20 @@ LIBEVAS_GENERIC_LOADERS_INSTALL_STAGING = YES
 
 LIBEVAS_GENERIC_LOADERS_DEPENDENCIES = host-pkgconf libefl zlib
 
-# For now, we only support the SVG loader
 # poppler >= 0.32 is not supported by the current version of
 # libevas-generic-loaders.
 LIBEVAS_GENERIC_LOADERS_CONF_OPTS += \
        --disable-poppler \
        --disable-spectre \
-       --disable-libraw \
        --disable-gstreamer
 
+ifeq ($(BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_LIBRAW),y)
+LIBEVAS_GENERIC_LOADERS_DEPENDENCIES += libraw
+LIBEVAS_GENERIC_LOADERS_CONF_OPTS += --enable-libraw
+else
+LIBEVAS_GENERIC_LOADERS_CONF_OPTS += --disable-libraw
+endif
+
 ifeq ($(BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG),y)
 LIBEVAS_GENERIC_LOADERS_DEPENDENCIES += librsvg cairo
 LIBEVAS_GENERIC_LOADERS_CONF_OPTS += --enable-svg