mplayer: use autodetection for dvdnav
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 19 Nov 2015 10:06:11 +0000 (10:06 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Dec 2015 12:38:15 +0000 (13:38 +0100)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index ad2d9dd61345e7215becfefb5afc27c1f0f1581a..3051afab17cbe72a48a4f739c9976f5a56b4910e 100644 (file)
@@ -125,9 +125,10 @@ MPLAYER_CONF_OPTS +=  \
 MPLAYER_DEPENDENCIES += libdvdread
 endif
 
+# We intentionally don't pass --enable-dvdnav to let the autodetection
+# find which library to link with.
 ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
 MPLAYER_CONF_OPTS +=  \
-       --enable-dvdnav \
        --with-dvdnav-config=$(STAGING_DIR)/usr/bin/dvdnav-config
 MPLAYER_DEPENDENCIES += libdvdnav
 endif